Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linux guest in VMware that I connect to from the Windows 7 host via putty, over the VM's host-only interface. When I close my laptop lid and it goes to sleep, then open it again, all my putty connections are disconnected.

Any setting I can tweak somewhere to keep those connections alive? It works in VirtualBox without any problem, but I can't use VirtualBox for various reasons I won't go into here.

share|improve this question
    
I was also looking for a solution to this problem. For another data point: on my WinXP laptop host, ssh connections to a Fedora guest would never disconnect when the laptop slept. When moving the same VM to a new Windows 7 laptop with the same version of VMware Player, all connections from the host to the guest drop when the laptop sleeps. –  user89935 Jul 12 '11 at 0:25

3 Answers 3

There is a fork of Putty called PuTTYtray which I've been able to get to reconnect to a VMWare host when my system awakes from sleep.

I found that you have to set both reconnect options to get it to work, not sure if it's just my setup.

You can find it here: [ https://puttytray.goeswhere.com/ ].

share|improve this answer

When the laptop goes to sleep, network activity stops and TCP connections close for lack of activity (assuming the O/S doesn't explicitly close them before going to sleep).

You could stop your laptop from going to sleep when you close it, but stopping it from disconnecting while sleeping is unlikely

\\Greg

share|improve this answer
    
Any idea why this works on VirtualBox then? –  Ben Dilts Apr 26 '11 at 15:39
    
Boy, I'd want to se that. I'll test it. What is the host O/S? –  uSlackr Apr 26 '11 at 23:59
    
Windows 7 host, Ubuntu Natty guest. –  Ben Dilts May 23 '11 at 21:27
    
Not true - this (PuTTY kept connected) worked well for me with PuTTY, VMWare with CentOS 5 and 6 VMs and Windows XP / 32 bit. Now I have Win 7 / 64 bit and can't remember that setting again. –  Alexander Farber Jan 17 '12 at 13:49
    
Perhaps there are power settings that affect this in the Win7 host. Suggest looking at and testing network adapter settings. –  uSlackr Jan 17 '12 at 18:23

You can use mosh to work-around this problem. It will transparently re-connect when the network connection comes back. Its not putty, and it has its own issues, but if you just want your command-line connection to survive a network disconnect mosh works great for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.