Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google set as my homepage and load it when I open a new tab.

Where in Firefox 3 the cursor would be inside the Google Search field so I could start typing my query, it now sits at the end of the URL.

Example: I want to look for "brown foxes." Instead of searching for "brown foxes" on an enter, as it used to be, I now go to google.com/brown foxes and get the Google 404 error.

Is there any way to force the focus back to the search box as it used to be?

share|improve this question

migrated from stackoverflow.com Apr 21 '11 at 21:38

This question came from our site for professional and enthusiast programmers.

    
What setting do you use to open Google in each new tab? Normally I use about:blank for homepage, but in trying to reproduce your problem I changed it to Google.com. However, I still have a blank window when I open a tab. –  Mr.Wizard May 10 '11 at 17:00

2 Answers 2

This is not an exact solution, but here are two better use-cases for you:

1: Use InstantFox. This will make your the Firefox AwesomeBar a universal search bar.

2: Use OpenDNS. This will route all your invalid URLs (eg. google.com/brown foxes) to valid search engine queries; among other things.

share|improve this answer

Better: use NewTabUrl plugin and untick option "select location bar after loading the new tab"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.