Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can no longer connect to a particular computer on my local network from my MBP (Mid 2010 running 10.6.6) via ethernet. I am trying to connect to a Mac G4 tower running 10.4.11. This has worked in the past but now does not.

My network is a simple home setup with 3 Mac laptops, a PC laptop, a Roku box for my TV, an Airport Extreme (802.1g) router, and a Lynksys switch.

An older MBP (Mid 2007 also running 10.6.6) can connect to the G4 on the same ethernet network. My Mid 2010 MBP can connect to the older MBP over ethernet. The Mid 2010 MBP can also connect via smb to a PC on my local network and can also connect to a PowerBook running 10.3.9 over ethernet. All of my systems can connect as clients to the Mid 2010 MBP over ethernet. Oddly, if I try to connect the MBP Mid 2010 to the G4 via Airport it connects fine.

The G4 shows up in the Mid 2010 Finder window sidebar under Shared. I can ping the G4 from the Mid 2010 over ethernet. I can even ssh into the G4 using the CLI from the Mid 2010 over ethernet. When I try to connect to the G4 over ethernet, via the Shared Icon in the sidebar or via Cmd-K, I instantly get a "Connection failed" message. I have the same problem from a different user account on the MBP Mid 2010. I have, via afp, tried both the server name and the IP, both of which work fine on the older MBP. No effect. I ran full Applejack on my Mid 2010. No effect. I reapplied the 10.6.6 Combo Updater. No effect. I deleted all references to the G4 in my keychain, but the "Connection failed" message comes before any attempt at authentication. Grasping that straw had no effect. I also deleted and readded the ethernet service in my MBP Mid 2010. No effect. I turned off the firewalls for both the MBP Mid 2010 and the G4. No effect. I don't see any relevant log entries but I am unsure which log records afp connection attempts. This one has me stumped.

share|improve this question
add comment

1 Answer

I may have found an answer in the Apple Support Communities. The gist of the fix is to use the device IP address instead of the device name.

share|improve this answer
    
Thank you for your response. Actually my problem went away after a power failure in my building. So I am assuming that the problem was with my router (Airport Extreme g) or my 5 port network switch. So if this happens again or to anyone reading this, try cycling power to your local network devices. It may help. –  John Oldham Jun 19 '11 at 4:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.