Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install aqua nmr and it requires gawk. I follow the directions in the install and in the make install step I get:

sh-3.2# make install
cd doc && make info
make[1]: Nothing to be done for `info'.
./mkinstalldirs /usr/local/bin /usr/local/share/awk \
                /usr/local/lib /usr/local/info /usr/local/man/man1 /usr/loca/libexec/awk
/opt/molmol-2k2-universal/install -c gawk /usr/local/bin && chmod 755 /usr/loca/bin/gawk
chmod: /usr/local/bin/gawk: No such file or directory
make: *** [install] Error 1

One thing that catches my eye is the /opt/molmol-2k2-universal/install...

I have no idea why it would be doing anything will molmol to install gawk. (MolMol is a molecular graphics program)

share|improve this question
    
Check your path. It looks like it wants to run install, and the molmol one is on there. Also, did you copy/paste the message? There are several loca instead of local. – Daniel Beck Apr 22 '11 at 8:42
    
Whats the best way of figuring out how to force it to use the system install instead of the molmol one? – Nate Apr 22 '11 at 17:15
    
Did you check your path to make sure I'm right about this? And if so, you tried setting your path to a list of directories that don't include /opt/molmol-2k2-universal? – Daniel Beck Apr 22 '11 at 17:21
    
Also, on OS X, it's easiest to install unix tools using one of the package managers Fink, Macports and Homebrew. – Daniel Beck Apr 22 '11 at 17:38
    
Using MacPort worked like a charm. Thanks! – Nate Apr 25 '11 at 21:51
up vote 0 down vote accepted

You have two options:

Clean up your path, so that it doesn't use this install

Or install it using Homebrew, Macports, or Fink instead.

brew install gawk
share|improve this answer
    
Ya thanks for your help! – Nate Apr 26 '11 at 5:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .