Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I install nodeJS like here shown: http://nodeguide.com/beginner.html

I have done these steps: wget http://nodejs.org/dist/node-v0.4.4.tar.gz and tar -xzf node-v0.4.4.tar.gz

But when I try this: cd node-v0.4.4.tar.gz it gives me an error: sh: line 0: cd: node-v0.4.4.tar.gz: Not a directory

And when I try this: ./configure it gives me sh: ./configure: No such file or directory

And finally when I try sudo make install it says sudo: sorry, you must have a tty to run sudo

Thank you very much

share|improve this question
add comment

migrated from stackoverflow.com Apr 22 '11 at 1:56

This question came from our site for professional and enthusiast programmers.

5 Answers

up vote 2 down vote accepted

You may need to unzip the file before untarring it.

gzip -d node-v0.4.4.tar.gz
tar -xvf node-v0.4.4.tar
cd node-v0.4.4
./configure
share|improve this answer
    
@Matthieu Cormier: it helped me, but when I try ./configure it gives me sh: ./configure: No such file or directory –  hey Apr 19 '11 at 21:09
    
try changing the permissions of the file with chmod 755 configure –  Matthieu Cormier Apr 19 '11 at 21:36
    
@Matthieu Cormier: through ftp or where? –  hey Apr 19 '11 at 21:39
    
if you do ls do you see the configure file? –  Matthieu Cormier Apr 19 '11 at 21:46
    
@Matthieu Cormier: no, I don't see it in ftp. –  hey Apr 19 '11 at 21:48
show 2 more comments

There is more simpler way:

$ sudo pip install nodeenv

# install latest node.js in sandbox
$ nodeenv test-node-env

# activate sandbox environment
$ source ./test-node-env/bin/activate

# work in sandbox
(test-node-env) $ node -v
v0.4.6

nodeenv - virtual environment for node.js

share|improve this answer
    
@shorrty: sudo: sorry, you must have a tty to run sudo –  hey Apr 20 '11 at 10:29
add comment

cd node-v0.4.4.tar.gz

node-v0.4.4.tar.gz is a file, not a directory that you can go into. Running

tar -xzf node-v0.4.4.tar.gz

should uncompress the tar.gz into a directory with a similar name.

share|improve this answer
    
@tladuke: I have done that, still the same error. –  hey Apr 19 '11 at 21:07
    
works for me. maybe it didn't download completely. –  tladuke Apr 19 '11 at 21:13
add comment

I highly recommend using nvm: https://github.com/creationix/nvm

nvm lets you install multiple versions of node and switch between them. It is as simple as this:

git clone git://github.com/creationix/nvm.git ~/.nvm
. ~/.nvm/nvm.sh
nvm install v0.4.7
nvm use v0.4.7

don't forget to add ~/.nvm/nvm.sh to your path so that you can use it in later sessions.

share|improve this answer
add comment

Had the exact same problem, and it was as simple as the download didn't complete, so it hadn't downloaded configure. Try starting from scratch and it should download configure along with the rest, and then when you do ./configure it should work.

If, after you cd into the directory starting with "node" (NOT the .tar.gz file, but rather the directory with almost the same name that was created by the "tar -xzf" command) and "ls", it doesn't show any file or directory called "configure", then it didn't all download, so go get the .tar.gz file again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.