Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd just installed my certs correctly into my Plesk 8.3.0, I encountered some trouble with the "CA didn't sign the certificate" warning message but I solved it.

Right now it seems to me that I installed certs in the right way for my domain, but... Chrome, Firefox, they still saying that the cert is expired and auto-signed... I really don't know how to fix it.

On Firefox I got this message:

Il certificato non è attendibile in quanto autofirmato. (autosigned)

Il certificato è valido solo per plesk. (plesk valid only)

Il certificato è scaduto il 04/03/2009 13:01. La data corrente è 22/04/2011 10:00. (no more valid)

(Codice di errore: sec_error_expired_issuer_certificate) (error code)

I checked the server date/time and it's everything OK, anyway, this seems to me that Plesk didn't "catch" the new cert...

Some advices?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I simply forgot to assign the Certificate to the static IP address, as can be readed here: http://kb.parallels.com/1736

After you created or uploaded new certificate into Plesk and wish to use it for domains you should set it for every IP you need, so domains use it when you access them via HTTPS. It can be done on page Server -> IP Addresses -> "choose IP" by selecting needed Certificate in "SSL Certificate" drop down menu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.