Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Me and my friend are trying to connect 3 computers together: 2 using XP and one Windows 7. We have successfully connected the XP computer that is connected to the router directly with cable and the Windows 7 computer but the other Windows XP computer doesn't show in any workgroup that we've created. What might be the problem?

share|improve this question

migrated from Apr 22 '11 at 11:13

This question came from our site for professional and enthusiast programmers.

What versions of XP you're using? Both are XP professional? – Naveed Ahmad Apr 22 '11 at 11:05
Yes they are both WinXP Professional – Martin Apr 22 '11 at 12:03

Ensure the workstation and browser services are started on the XP machine that is not appearing.

share|improve this answer

Check that the firewall on the 2nd XP machine is configured to let local network traffic through in both directions.

share|improve this answer
  • In XP's Firewall (firewall.cpl) enable the "File and Printer Sharing" exception;

    (if you use a third-party firewall, allow TCP 139, TCP 445, UDP 137, UDP 138 and ICMP Echo)

  • Use Wireshark to watch for browsing traffic (display filter smb || nbss || nbns || netbios || browser)

  • In 7, try nbtstat -a <HOSTNAME> and nbtstat -A <IPADDRESS> (where <HOSTNAME> and <IPADDRESS> are the XP computer's name and IP address respectively); also check if they return the correct workgroup name.

  • Try restaring the "Computer Browser" service in all computers

share|improve this answer
File and printer sharing is enabled nbtstat says that the host cannot be found (tried with IP adress also) restarted the computer browser service and it didn't have effect – Martin Apr 22 '11 at 12:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .