Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After updating to Opera 11, I find that I can't open a link in a new tab using the context menu.

I point my mouse on the desired link, press the right mouse button, and select from the context menu "Open in new tab" or "Open in new window" but nothing happens.

What is wrong? Which settings should I check?

UPD: there are 5 "Open ..." variants in the context menu and no one works.

UPD2: My keyboard scheme is changed, but even after switching to default, menu doesnt work.

share|improve this question
    
Are you using Windows, Linux, Mac OS X, or some other operating system? –  kiamlaluno Apr 22 '11 at 14:33
    
Linux Os is used. –  osgx Apr 22 '11 at 14:33
    
Which GUI are you using? I wonder if there might be a known issue with a particular GUI. Also, you should report this to Opera (I find they have been adding my feature suggestions that I submit through here too): Help menu -> Report a site problem –  Randolf Richardson Apr 22 '11 at 15:17
    
I use KDE, but I can't say what gui framework is used by Opera (I downloaded tar.gz, and it does not link to any framework). –  osgx Apr 22 '11 at 15:28

1 Answer 1

up vote 2 down vote accepted

You may have another dialogue open for a different tab, such as the prompt to bookmark a page, which will prevent other GUI options from functioning correctly. The easy way to clear up this particular problem is to just exit Opera, then come back (it will restore all your tabs, and Back/Forward history so you won't lose your position in your current workflow).

Alternatively, to open a link in a new tab, hold the Shift key (either one) while clicking once (with the left mouse button [since you seem to be using the default "right-handed mouse mode"]).

I use this feature frequently, and I find that holding down the Shift key to start a link in a new tab is a wonderful convenience.

share|improve this answer
    
restarting opera didn't help. Yes, Shift works (I use CTRL for this with other browser); but I also want sometimes to use context menu; without touching a keyboard. –  osgx Apr 22 '11 at 14:34
    
If you're using the keyboard, you can also hold down the Shift key while pressing Enter to follow the selected link (using CTRL-Down/CTRL-Up) into a new tab. I'm sorry, I'm not sure what's happened to your context menu, and am only trying to help you get working temporarily with alternatives until your context menu starts working again. –  Randolf Richardson Apr 22 '11 at 14:37
    
Randolf, can I change this key from Shift and Ctrl-Shift (background tab) to Ctrl+Shift and Ctrl? –  osgx Apr 22 '11 at 14:40
1  
For those who are interested, a complete list of all keyboard functions in Opera can be found here (for anyone who's new to Opera, this is a "must read" even if you mostly use the mouse): help.opera.com/Windows/11.10/en/keyboard.html –  Randolf Richardson Apr 22 '11 at 14:41
    
@osgx: When modifying the keystrokes (see my next comment), I VERY STRONGLY RECOMMEND that you first use the "Duplicate" option to create your own "customized keyboard set" instead of modifying the default one directly. This way, you have a "manufacturer default" to fall back on in case you ever need it. –  Randolf Richardson Apr 22 '11 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.