Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed all the steps in https://help.ubuntu.com/8.04/serverguide/C/subversion.html but when I try to do:

svn co https://localhost/svn

I get:

 svn: Repository moved permanently to 'https://localhost/svn/'

...and when I do:

 svn co https://localhost/svn/

I get the same error again. When I try:

 svn co https://localhost/svn/testrepo

I get:

 svn: Could not open the requested SVN filesystem

In apache logs I see:

 can't open file /home/myname/testrepo/testrepo/format

In my apache2.conf I have:

<Location /svn>
     DAV svn
     SVNParentPath /home/myname/testrepo
     SVNListParentPath On
     AuthType Basic
     AuthName "myrepo"
     AuthUserFile /etc/subversion/passwd
     <LimitExcept GET PROPFIND OPTIONS REPORT>
         Require valid-user
     <LimitExcept>
</Location>

I also tried previously with "SVNPath" instead of "parentpath" without success.

Please help, I'm desperate!! I tried all combination of paths I could think of...

share|improve this question
up vote 6 down vote accepted

It seems as SVNParentPath is pointing directly to your repository, rather than to a directory that contains your repository.

Create a folder called projects in your home folder

mkdir /home/myname/projects

Move your repository into projects.

mv /home/myname/testrepo /home/myname/projects

Change the ownership of projects to www-data.

sudo chown -R www-data:www-data /home/myname/projects

In apache2.conf, change your declaration of SVNParentPath to

SVNParentPath /home/myname/projects

Restart your Apache server.

Now try checking out your repository.

svn co https://localhost/svn/testrepo
share|improve this answer
    
it worked!! thank you very much! – Jason Apr 23 '11 at 7:31
    
i dont understand how this worked because for me when i do SVNParentPath /home/myname/projects. and restart the apache server, i get an error saying "syntax error on apache2.conf" same line where i added "SVNParentPath /home/myname/projects" – jonney Jun 12 '12 at 9:49

For Windows users (if someone has a similar problem under Windows):

The problem could be file access permissions.

I solved my problem by moving the repository to the location where Apache can read and write the files. In my case (CollabNet Subversion Edge) the path was C:\csvn\data\repositories.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .