Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed VisualBoyAdvanced from the Ubuntu repos and loaded my ROM into the game. However, when I play I can't get it to go at regular speed, it's stuck at 85% throttle. I've tried manually setting the throttle to 100%, but that doesn't work.

Also, when I hold the spacebar to "speed up", it get's choppy and is unplayable. Any fixes to this? Does this have anything to do with frame-dropping?

Edit: I think it's worth mentioning that I'm not using a GUI for this and I'm on an eeePC. Is it possible that the onboard graphics aren't enough. This seems strange because it's just a GBA game. Nothing fancy.

share|improve this question
up vote 1 down vote accepted

Alright I finally figured out how to fix this, however I still don't know WHY is was so slow. The ROM has to be called with VisualBoyAdvance like this:

VisualBoyAdvance --flash-128k --throttle=100 --frameskip=3 Path/to/ROM

The flash-128k makes some games work better than others, but the key option here is the frameskip. I tried skipping 2 frames and it was quicker but could be better. I decided to use 3 on my eeePC, but see what number works for you.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .