Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For development on local machine I've set domains with custom top level domain .nt. But Google Chrome doesn't know about this top level domain, so, if I enter example.nt in location bar, then google doesn't open that location, but opens search with that string (though it shows a bar proposing that I wanted to open location instead of searching if DNS request for that location satisfies). So I can either type http://example.nt, type example.nt/ or open that location to teach Google Chrome, but in any case there will be slash at the end of location. All this is not very convenient, also I don't like this slash, is it possible to tell Google Chrome, that .nt is a normal TLD, so just open locations in with it?

share|improve this question
add comment

5 Answers 5

up vote 7 down vote accepted

According to this bug posted: http://code.google.com/p/chromium/issues/detail?id=30636

Google will not be fixing the issue you have. The only method should be to use http://example.nt I don't see why that won't work.

share|improve this answer
5  
That will work, but people aren't in the habit if typing "http://" in front of everything. When was the last time you wanted to go to a site and started typing "http://"? –  Asa Ayers Oct 10 '11 at 16:56
11  
For quick lookup for anyone else seeing this question, typing example.nt/ (with a single trailing slash) will cause chrome to treat it as a URL. This is much less annoying than having to add http:// to everything. –  eouw0o83hf Oct 4 '12 at 13:54
1  
There's a workaround that just involves updating the search engine settings. See my answer below. –  simmbot Sep 17 '13 at 21:34
add comment

Fortunately there is a fairly simple workaround that doesn't involve code.

  1. Go to Settings
  2. Manage search engines...
  3. Add a new search engine and use these as the 3 values:
    a. Default
    b. %s
    c. http://%s/
  4. Make default
share|improve this answer
1  
wouldn't this break search? –  Louis Sep 17 '13 at 22:08
2  
Google wouldn't be the default anymore. What I also did was set "g" as the shortcut for Google, so that it's almost as seamless as out-of-box google search. –  simmbot Oct 7 '13 at 17:52
    
You can also prefix any search phrase with "?", and the combo Ctrl+E does this for you. –  defines Jul 10 at 15:00
add comment

I run my own local DNS server (BIND on Linux) which resolves LAN domains using a custom TLD and then recurses non-LAN to OpenDNS. I've never experienced any issues like this. Are you sure your local DNS is correctly resolving .nt domains?

share|improve this answer
    
I use /etc/hosts with script generated entries and all domains are resolved correctly. –  tig Apr 25 '11 at 13:23
    
The thing is with /etc/hosts is that a program can't resolve things in it and get the nameserver of a specific domain, I believe. e.g., if you have "example.nt" in your hosts file, it can't ask which nameserver is responsible for the ".nt" domain, because there is none. Chrome does some DNS checks to work around DNS providers that redirect bad DNS resolutions to ad pages and I'll bet this has something to do with it. You might try running a local DNS server. –  ultrasawblade Apr 25 '11 at 14:33
    
But Chrome proposes me to go to location if domain is present in /etc/hosts. Also the question was more on possibility to add .nt to list of "normal top level domains", if I try to go to location aristnraisetnrast.com, which dose not exist, Chrome doesn't search for it, I just get "This webpage is not available", but if I try domain.nt which does exist, than I get a search page. –  tig Apr 25 '11 at 15:56
add comment

As Sandeep Bansal said, this is a bug that will never be fixed in Chrome. But I made a workaround for it and posted it here: http://code.google.com/p/chromium/issues/detail?id=30636#c38

share|improve this answer
1  
Instead of just linking to another page, it would be preferable to post a full answer here. –  Dennis Jan 16 '13 at 3:27
add comment

Similarly to simmbot, I've created a search engine with a keyword of 'l' (my local TLD is .l). The URL is http://%s.l. Then, I simply type "l mysite" in the address bar and it takes me to mysite.l.

Alternatively, you can simply add a slash at the end, and Chrome won't consider it a search. (See http://stackoverflow.com/a/7877750/974981)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.