Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just built my new PC 2 days ago. It works extremely well, except that it can't go into hybrid sleep mode.

My PC is running Windows 7 Professional X64

With hybrid sleep allowed, when I click sleep, the screen goes black and the computer shuts down (no lights, no fans, nothing). The power LED is off clompetely (no blinking). Clicking the mouse or keyboard has no effect, the PC wont wake up. If I push the power button, the PC starts and I get the screen telling we Windows crashed and it asks me if I want to run in safe mode or not.

I am able to put the PC to sleep by disallowing hybrid sleep, but that is pretty useless. It simply cuts output to the display while most components stay active (all the fans keep turning). In this case, I can awake the PC using the keyboard or mouse.

System specs:

  • Motherboard: MSI P67A-GD65 (B3)
  • DVD: Samsung SH-S243D/BEBE 24X Black
  • Heatsink: Coolermaster Hyper 212 Plus
  • Case: Coolermaster CM 690 II Advanced
  • Power Supply: OCZ ModXStream Pro 700W
  • RAM: G.SKILL Ripjaws X F3-12800CL9D-8GBXL
  • HDD: Western Digital WD1002FAEX
  • GPU: XFX Radeon HD 6950 XXX 830MHZ 1GB 5.2GHZ

In the BIOS, i have set the 2 options in ACPI Settings to:

  • ACPI Stanby state = S3 (other choice is S1)
  • Power LED = Blinking (other choice is Dual Color)

What should I do to make hybrid sleep work?

share|improve this question
    
Can you post the problem information from Action Center Reliability Monitor so that we know exactly how the system crashed? –  DragonLord Apr 23 '11 at 18:35
    
Problem: Windows was not properly shut down –  bouvierr Apr 23 '11 at 18:47
    
The previous system shutdown at 9:26:52 AM on ‎23/‎04/‎2011 was unexpected. –  bouvierr Apr 23 '11 at 18:48
    
This is not a system crash in the sense of a Stop error or BSOD; it is simply a "hard" (improper) shutdown. You might have some sort of hardware issue preventing proper writing of RAM to the disk. Can you hibernate the system without placing it into a low-power sleep state (write RAM to disk and shut down)? –  DragonLord Apr 23 '11 at 19:28
    
If the system did crash with a Stop error, there would be an event in the Reliability Monitor that says "Windows stopped working". –  DragonLord Apr 23 '11 at 19:36

2 Answers 2

up vote 0 down vote accepted

I finally found the solution. My hard disk was plugged into one of the SATA 6GB/s ports by Marvell 9128 controller. Plugging the drive into one of the SATA 6GB/s ports by Intel P67 PCH controller solved the problem. The computer now goes to sleep in hybrid mode and wakes up using either the mouse or keyboard!

share|improve this answer

Failure to sleep properly can be caused by problems with device drivers. Make sure you installed the latest drivers for your motherboard, GPU and any other devices in the system. If you have any USB devices other than keyboard and mouse, remove them to see if hybrid sleep works. Try disabling your motherboard's onboard sound. You want to try to find which driver is causing the sleep to fail, so the basic approach is to disable as many devices as possible until sleep works, then enable them one at a time until sleep fails again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.