Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with the write protection of Windows 7. All my files in my users folder are protected and it is impossible to remove. When I uncheck the checkbox, a progressbar runs threw but everything stays unchanged. I've also tried to change it in the command line with

attrib -r C:\Users\Username\*.* /d /s

but nothing has changed. What else can I try? Thanyou!

share|improve this question
I am desperate. I've tried everything. chkdsk.exe doesn't help, check disk on start-up doesn't help. I can't even download music from the iTunes store because the entire library is locked. – skotschi Apr 28 '11 at 14:02
What version of Windows 7? – Not Kyle stop stalking me Apr 28 '11 at 15:04
The /d switch in your command line means it will apply only to directories, and the ReadOnly attribute on directories is pretty much meaningless. If you cannot create files in those directories, there is something else preventing it, such as permissions. – kreemoweet Jan 31 '12 at 5:52
@kreemoweet, you can use the attribute to give folders their own icons. ;-) But yes, the problem should be solved by running it again without the /d switch to strip the read-only attribute from files. – Synetech Sep 4 '12 at 15:59
Do you have write permission for the files? In the GUI, right click on the directory, go into the security tab, and give yourself full control. Then, try to change the attributes again. – Konstantin Naryshkin Sep 4 '12 at 16:16

Try a chkdsk.exe C: to do a basic check of the disk. Sometimes this fixes your problem. Make sure to use an elevated command line.

share|improve this answer
When I start the chkdsk.exe the first thing it says is: Warning! The parameter F wasn't stated. chkdsk works in protected mode. Sorry if it istn't the acurate warning, but I have to translate it. – skotschi Apr 23 '11 at 20:47
@skotschi, see… – Moab Apr 24 '11 at 3:22

Maybe it is a virus?
I saw joke-viruses like that. They lock files simply opening them in "lock read write" mode. Try Sysinternals' Handle.exe . If the files are locked with that method, Handle will give you the name of locker.

share|improve this answer

Download Hiren Boot Cd 15.2, burn to CD, then boot your computer from CD. Executes the mini version of Windows XP. Optimizations in the disk section there is a simple application to reset the NTFS permissions of a folder or entire disk.

share|improve this answer

Move the files to a fat or fat32 formatted thumbdrive (or any drive) and back.

share|improve this answer
Can you expand, maybe to explain why moving files to a FAT-formatted partition would allow this to work? Maybe also mention any limits of using a FAT-style partition (i.e. limited to 4GB file size, unless you're using exFAT)? – Canadian Luke Jun 20 '14 at 15:23

May be you do not have needed access rights for this folder? In this case login in Windows as Admin, open this folder (C:\Users\Your user) and change (add ownership as Your user) access rules (Properties->Security->Edit) to this folder.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .