Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows 7 64-bit and have installed the latest Haali Media Splitter.

How can I make Windows Explorer show thumbnails for MKV files?

share|improve this question
up vote 5 down vote accepted

Icaros 1.2.5 works, if it doesn't work alone, install Shark007 Codec Pack!

share|improve this answer
  1. Go to the Haali Media Splitter Properties.

  2. Click the Options tab, expand Explorer integration and select Enable thumbnails extraction:

    Haali Media Splitter Properties

  3. Set the value to Yes. You might want to configure the Thumbnails offset (a milliseconds value) to say, 10000 to give you more representative thumbnails.

  4. Restart the machine.

share|improve this answer
tried, doesn't work. – Henry Jun 29 '11 at 0:10

It doesn't seem to work at first with Windows 7 64-bit.

You need to add the following lines to the registry:



Curiously, a whole day after applying those changes, thumbnails for mkv files began to show up in Explorer, so it does work (with Haali MKV Splitter on Windows 7 64-bit systems).

share|improve this answer
where does {c5a40261-cd64-4ccf-84cb-c394da41d590} come from? Looking at my reg it's {9DBD2C50-62AD-11D0-B806-00C04FD706EC} for .mpg and .avi – Henry Sep 28 '11 at 21:25
tried both, restarted, they don't work... or maybe i really need to wait 'a whole day'? – Henry Sep 28 '11 at 21:58
wow, it works, but without offset it's kindda useless. 80% of them are just... black – Henry Sep 29 '11 at 6:24
Sadly I don't know how to change this. It seems use the same offset no matter what value I set in haali options. – Realcool Oct 9 '11 at 0:38
I think it stops working again, sad. – Henry Oct 9 '11 at 17:29

MediaPreview as suggested per lifehacker does a fine job, also for other formats such as ogg and 3gp.

share|improve this answer

It's problem caused by Windows 64 bit. Download K-lite Codec Pack for 64bit and everything works out fine. Tried. Note: Use it together with K-Lite Codec PAck for 32bit for best result.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .