Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem with users and windows installer Only the primary user can start any program. The primary user can do anything. All users have admin rights. As a example if trying to open/start Internet Explorer all users will get the error message. (The Windows Installer Server could not be accessed. This can occur if the windows installer is not correctly installed.) Some programs will get this error code. 26EE0668-A00A-4407-9371-BEB064C98683

I think what started the problem one of the users switched users during a windows update.

Does each user have their own copy of the Windows Installer?

If I create another user with admin rights the new user gets the same error.

share|improve this question
    
Have you tried using System Restore to go back to a poin tin time before the suspect update happened? –  techie007 Apr 25 '11 at 18:16
add comment

1 Answer

Sounds like something is corrupted with the Windows Installer or the registry. MS has a KB article for this error occurring on Windows XP, which should still largely translate to Windows 7.

Here's what I'd do:

  1. Start an elevated command prompt.
  2. Run where msiexec.exe and take note of the location. C:\Windows\system32.msiexec.exe is normal.
  3. Run reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer /v ImagePath and make sure the location from #1 corresponds. %systemroot%\system32\msiexec.exe /V is normal.
  4. Run services.msc and make sure that the Windows Installer service is set to Manual or Automatic.
  5. Run msiexec.exe /unregister followed by msiexec.exe /regserver. If you're running 64-bit Windows, you also need to run %windir%\Syswow64\Msiexec /unregister and %windir%\Syswow64\Msiexec /regserver.

Some people have experienced a bug in Microsoft's CEIP which causes explorer.exe or msiexec.exe to crash. The fix is to browse to HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions and delete any values there other than (default).

You could also try reinstalling Service Pack 1. If you still have no luck, then the most common fix would be a repair install of Windows.

ETA: No, each user does not have their own copy of the Windows Installer. It is shared system-wide.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.