Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been tinkering for hours and I'm becoming desperate.

I want tabs! I like tabs, I see no advantage in using spaces and therefore I ident with tabs (alignment is done with spaces though). But I can't get AUCTeX (or LaTeX-mode for that matter) to use tabs - and it does not seem like anyone else in the world has ever wanted it to.

I'm on Ubuntu so AUCTeX is installed by default, and I guess the relevant parts from my .emacs are the following:

(setq-default LaTeX-default-offset 8)
(setq-default TeX-newline-function 'newline-and-indent)
(setq-default indent-tabs-mode t) ; I want tabs. I like tabs
(setq-default standard-indent 8) ; A tab is 8 spaces
(setq-default tab-width 8) ; A tab is still 8 spaces... what's the difference to the above?

With these settings, it's still indenting using 2(!!) spaces. Please Help and keep in mind that I just switched from vi, so I might not have a firm grasp on every concept of emacs ;)

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

in the menu bar, click LaTeX -> Customize AuCTeX -> Browse options. In there, go to the TeX Indentation group node and follow it. Within the group, activate the Latex Indentation node to make the options visible. Change the Latex Indent Level variable from 2 to 8; set for current session (to avoid messing thing up if they don't turn out how you hope, give it a try and let us know how it turned out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.