Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot without X or hit Ctrl+Alt+F1 I have very low screen resolution.(large font)

Normal for the screen is 1920x1200.

Can I change it?

Does it have to do with Nvidia?

Ubuntu10.10-x64-Nvidia

share|improve this question
up vote 1 down vote accepted

colechristensen is correct but it should be pointed out that you append vga=ask to the end of the "linux" line, a line that looks like linux /boot/vmlinuz26 root=.... In fact, you don't need to edit grub.cfg; when in grub, type E and you can do the edit on the fly, then hit "Ctrl-X" to execute; the modification made there is temporary.

You will then be confronted with a list of possible VGA modes, but most likely 1920x1200 will be absent. This is a common bug in the VGA BIOS of graphics cards not listing resolutions higher than 1280x1024, and the only easy solution is to use the open-source video driver. With the open-source driver KMS(kernel mode-setting) will be utilized, giving the kernel access to "fancy" modes like 1920x1200. Without KMS, you can easily access those fancy modes (AFAIK) only in X.

share|improve this answer

Yes.

Edit the kernel arguments in grub.conf (or menu.1st, wherever the grub config actually is).

The first time you run is insert the argument vga=ask. This will prompt you with a list of possible resolutions the next time you boot. Try them out until you find one you like, then set that in your grub config. I believe mine is vga=0x344.

EDIT: Apparently ubuntu is using something more complicated than I'm accustomed to.

share|improve this answer
    
I don't have either grub.conf or menu.1st. Edit the kernel arguments in grub.conf (or menu.1st, wherever the grub config actually is). What do I edit it to? – winchendonsprings Apr 25 '11 at 1:00
    
Yes you do. Look in /boot/ /boot/grub/ – colechristensen Apr 25 '11 at 1:10
    
dl.dropbox.com/u/545099/Screenshot-3333.png that is /boot/grub/ – winchendonsprings Apr 25 '11 at 1:18
    
Try grub.cfg then. – colechristensen Apr 25 '11 at 1:24
    
Here is the only part of that file that looks relevent. function load_video { insmod vbe insmod vga } insmod part_msdos insmod ext2 set root='(hd2,msdos1)' search --no-floppy --fs-uuid --set 937b2299-48ff-4a9c-8228-67ed4453e8fb if loadfont /usr/share/grub/unicode.pf2 ; then set gfxmode=640x480 load_video insmod gfxterm fi What should I do to it? – winchendonsprings Apr 25 '11 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .