Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a new Lenovo S20 and I am having trouble loading Linux. I've loaded these variants with no success:

  • Ubuntu desktop
  • Ubuntu server
  • Linux Mint
  • CentOS
  • vmWare esxi

The live CD's run, and very nicely at that. But once I install to the workstation they won't boot. I just get a blank screen. I've tried different bootloaders.. I've toyed with different BIOS settings.. I've even installed to different drives (a hard disk and an SSD).

Maybe a hint: BSD installs and runs with no problem at all. I have PC-BSD running at the moment. It's nice, maybe I'll keep it. But I'd rather have Linux.

My amateur computer science mind sees this as

  • not a boot loader issue (recovery mode shows Linux seems to be loading to a point.. but I can't see the script line just before the lockup)
  • not graphics related; UB Server and vmWare are text-only and they won't load either
  • probably not a bios issue (liveCDs run and other people run Linux on S20s)
  • not hardware (Windows and BSD run on this one)

If anyone has an idea.. or has even just point me in a direction to poke around more, that would be great.

What I'd someday like to do is get VMware to run.. then go in to virtual machines as desired.

share|improve this question
Solved. I don't know how I solved it.. but I did. I also had MS Vista on the Lenovo. I upgraded that Vista disk to Win7. After I installed Win7 I thought I'd give Linux another shot. Whatever installing Win7 did, also fixed the Linux install problems. I wish I knew what exactly what changed. – Paulb May 8 '11 at 13:07
up vote 2 down vote accepted

Can you see the output of the boot process, or do all distibutions you have installed use a bootsplash to hide this information? Ich you are able to enter the boot manager (I'm assuming its's grub here) you may want to edit the boot entries and remove any "silent" or "quiet" flags.

If your machine prints "loading grub" or something similar try pressing ESC a few times to enter the boot loader's menu. Sometimes this isn't even required, since the boot loader always displays this menu. loading gub

Then you should be able to select a boot entry with the cursor keys. (Press ANY key to prevent your machine to continue booting due to a timeout)

Mark the preselected entry and press e. You'll be able to edit the entry just like a textfile. Remove the flags and follow the instructions on screen to boot. On Debian hit Ctrl+x to boot.

(note the flag quiet on line 6 - which is line 8 actually) enter image description here

share|improve this answer
Thanks for the idea. I'll try it later today and let you know what happens. Note: I never get to any text on the screen such as Grub.. so I don't know if I'll be able to escape into it. – Paulb Apr 25 '11 at 11:14
try hammering ESC after pressing the power button. Maybe you'll get to the grub screen, maybe you're unlucky and the screen has been disabled alltogether. But i think the Ubuntu-Distros allow you to enter the grub screen. YOu might also want to try Debian... =) – lajuette Apr 25 '11 at 20:52

We installed Linux using the following steps:

  1. Put the default BIOS configuration.
  2. Install a fresh distribution of Linux (we tried with Fedora 15 and Ubuntu 10.04, 64 Bit)
  3. Changed the BIOS configuration (activating the RAID)
share|improve this answer

For future reference:

I had the same problem on a Toshiba netbook (don't remember the model number). Booting from a LiveCD worked fine. When I would boot from the hard drive, the system would hang for a very long time (more than ten minutes), then resume booting. The problem was a BIOS setting. I had to change the SATA controller (?) from its default setting to "compatibility".

I may be misremembering some details. I'll edit this post tonight and add more information.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.