Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

MacBook Pro, NVidia 9400M, Windows 7 64-bit.

When I connect external monitor and I would like to duplicate display or extend it, I always get this error, despite monitor is correctly recognized. When trying to do the same but via NVidia Control Panel, my new settings are silently rejected (i.e. when I press apply, settings are reverted back to defaults).

I found several solutions, like:

  • deleting HKEY_CURRENT_USER\Software\Microsoft\MobilePC\TMM registry entry -- I don't have such one though,

  • updating graphics card driver -- driver is up to date,

  • using graphics card control panel, instead of windows -- as I wrote above, changes are silently rejected.

Is there any other way to use external monitor using Windows 7?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Does it work if you disable the internal monitor and enable the external monitor? This is the normal behavior if you try to activate concurrent displays that can't be active - most laptops will give this behavior if you try to activate two external displays while leaving the internal enabled (since most laptops only support two video outputs). It's possible that this laptop only supports one simultaneous video output but I don't know enough about Macs to say that - it seems odd, but it would fit the behavior you're seeing. It's also possible this is a result of the driver you're using.

share|improve this answer
    
Thank you. I am marking your reply as answer, however now my config works and I don't know why. This time I plugged external monitor a bit earlier -- at login screen -- and external monitor kicked in. I can configure displays as I want, no problems. Mystery :-/ Next time I will be in trouble I will try your approach (btw. I have only one external monitor, not two). –  greenoldman Apr 25 '11 at 20:20
    
I'm guessing it's an artifact of running Windows on a Mac. That's odd behavior for Win7. Still, glad it's working! –  Shinrai Apr 25 '11 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.