Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have to use pci=nocrs with my hardware to get my USB ports to work. But because I have to use an external USB DVD drive, I have difficulty booting without passing that parameter.

I am able to edit the files on the disk before burning it, but it appears to all be pretty compressed and unreadable by a human. Are there any tricks or anything for editing grub boot parameters on a livecd like this? I'm using the Gnome 3 livecd (opensuse) if that matters.

The way I'm doing it on my Kubuntu install (not livecd) is this: GRUB_CMDLINE_LINUX="pci=nocrs" and then running update-grub.

I could probably do it "on-the-fly" each time I boot, but I'd like to avoid that. I'd also like to avoid installing it to the HDD (which, I know, would definitely solve my problem)

I am, however, open to making a new boot DVD if there's some way I could boot into the OS just once by manually (and temporarily) editing the parameter at boot time and then making the necessary changes from within the OS and then reauthoring the DVD based on the current image loaded in memory. (if there's any way to do that)


The /boot/grub directory only has one file, and that's mbrid. The contents of that file is only the following: 0x131f4e78

I'm guessing the filesystem is compressed into a single file which is uncompressed one piece at a time at runtime.

Also, here is the directory structure of the disk: (courtesy the TREE command in DOS)

│   GNOME_3-read-only.x86_64-1.0.0
│   config.isoclient
    │       mbrid
            │   08000600.spl
            │   10240768.spl
            │   12801024.spl
            │   16x16.fnt
            │   af.hlp
            │   ar.hlp
            │   back.jpg
            │   bootlogo
            │   ca.hlp
            │   chain.c32
            │   cs.hlp
            │   da.hlp
            │   de.hlp
            │   el.hlp
            │   en.hlp
            │   en.tlk
            │   es.hlp
            │   et.hlp
            │   fi.hlp
            │   fr.hlp
            │   gfxboot.c32
            │   gfxboot.cfg
            │   gu.hlp
            │   hapysuse.mod
            │   hr.hlp
            │   hu.hlp
            │   initrd
            │   isolinux.bin
            │   isolinux.cfg
            │   isolinux.msg
            │   it.hlp
            │   ja.hlp
            │   ko.hlp
            │   kroete.dat
            │   ky.hlp
            │   linux
            │   lt.hlp
            │   mboot.c32
            │   memtest
            │   mr.hlp
            │   nb.hlp
            │   nl.hlp
            │   pa.hlp
            │   pabout.txt
            │   panim.jpg
            │   panim_a.jpg
            │   pback.jpg
            │   phead.jpg
            │   pl.hlp
            │   pt.hlp
            │   pt_BR.hlp
            │   ro.hlp
            │   ru.hlp
            │   sk.hlp
            │   sv.hlp
            │   text.jpg
            │   th.hlp
            │   timer_a.jpg
            │   uk.hlp
            │   welcome.jpg
            │   xh.hlp
            │   zh_CN.hlp
            │   zh_TW.hlp

edit 2:

Here are the contents of /boot/x86_64/loader/isolinux.cfg. This does, in fact, appear to be the correct place to put it. I will test it later tonight and update this to reflect the solution.

default GNOME3
implicit 1
display isolinux.msg
ui gfxboot bootlogo isolinux.msg
prompt   1
timeout  200
label GNOME3
  kernel linux
  append initrd=initrd ramdisk_size=512000 ramdisk_blocksize=4096 splash=silent showopts 
label Failsafe_--_GNOME3
  kernel linux
  append initrd=initrd ramdisk_size=512000 ramdisk_blocksize=4096 splash=silent showopts ide=nodma apm=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off

label harddisk
  localboot 0x80

label memtest
  kernel memtest

It looks like I'll be able to add my parameter to the end of this: append initrd=initrd ramdisk_size=512000 ramdisk_blocksize=4096 splash=silent showopts

share|improve this question

A LiveCD will have a directory structure like this:

|-- autorun.inf
|-- boot
|   |-- grub
|   |   |-- desktops
|   |   |-- extended
|   |   |-- grldr
|   |   |-- iso9660_stage1_5
|   |   |-- menu.lst <--- GRUB Menu Listing
|   |   |-- message
|   |   `-- stage2
|   |-- initrd-nx08.gz
|   |-- pxelinux.0
|   |-- pxelinux.cfg
|   |   |-- default
|   |   `-- default2
|   |-- syslinux
|   |   `-- syslinux.cfg
|   |-- syslinux.bin
|   |-- vesamenu.c32
|   `-- vmlinuz-nx08
|-- boot.catalog
`-- ...

You want to modify the ISO and edit the "grub.lst" file (which you can search for if you do not find). You then want to repack it into a bootable ISO and burn it to disk.

I've seen ISOMaster recommended for such tasks, so that'd be the first leaf I turn over.

Some distributions also use isolinux, and their config details can be found in isolinux.cfg, and use a LILO-like syntax, which uses append to add arguments.

share|improve this answer
I updated the question to address your answer. As you can see from the directory tree I included, there is no grub.lst on the disk. (at least not as an standalone uncompressed file - it might be in a tarball somewhere) Also, I believe (but I could be wrong) GRUB2 (the latest version of GRUB) depreciated grub.lst and replaced it with /etc/default/grub. When I boot into the disk, I am able to navigate to that directory (/etc/default/), but it doesn't show up on the disk. I'm guessing it's compressed in a file somewhere but I don't actually know. – advs89 Apr 26 '11 at 19:47
@advs89 It may very well be that you will find the config in isolinux.cfg - I've not dealt with isolinux, so that this may not be the case (and note that my example uses syslinux, which may decrease its applicability to your situation). – new123456 Apr 26 '11 at 21:28
It looks like isolinux.cfg is going to be it. I'll mark you as accepted after I try it (just to make sure). – advs89 Apr 26 '11 at 21:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.