Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus m2n sli deluxe mainboard. I ran the Asus update utility (wish I didn't, it is buggy) and it started to loop (my OS is Windows 7 Pro 64-bit). after 15 minutes, I restarted my PC. as I expected the BIOS became corrupted. on boot, the screen shows nothing, no post screen, no buzzer sound, nothing!. so, I cleared the CMOS but I still get no response (I'm sure the jumper is at the correct position).

is there anything else I can do?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Regrettably, this motherboard seems to be very iffy when it comes to BIOS updates - I trashed one about 3 weeks ago trying to flash it.

The board is supposed to have a 'crashfree' BIOS and the recovery instructions (which I tried without success) are outlined here (different board variant, but same procedure): http://www.motherboardpoint.com/m2n32-sli-deluxe-wireless-and-bios-update-problems-t61048.html give it a go - hopefully it will work for you.

I was able to grab a replacement BIOS chip from an identical duff board we were just about to scrap for other reasons, but they are also available on ebay for about 10 UK pounds.

Edit: Position of BIOS in socket (circled), below CMOS battery:

M2N SLI motherboard

share|improve this answer
1  
i read the solution at the link you provided. oh, the horror! besides not having a PCI video card, i'm not sure if i got the discharging myself onto the chassis part. i am pretty sure that i cannot solder another bios chip, too. thanks for the solution though. this card is as good as junk now! oh, you monstrous ASUS update utility how i hate you and if i had known you were so buggy! –  sterz Apr 25 '11 at 22:13
    
@sterz: Do check again as my BIOS was in a socket so no soldering required. –  Linker3000 Apr 25 '11 at 22:20
    
here is a picture of my bios: i.imgur.com/pVKny.jpg do you think it is socketed? it looked to me that it is soldered. –  sterz Apr 26 '11 at 13:21
    
@sterz: You're right that's soldered directly to the board. Darn. –  Linker3000 Apr 26 '11 at 15:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.