Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Network topography: Internet === Verizon DSL Modem === Time Capsule Router === Mac Mini web server

I go to icanhazip.com and grab my public IP address. I throw it into a web browser and get...my Modem's admin interface. I didn't expect that. I spent an hour but was unable to get any further.

My configuration: The Verizon DSL Modem's firewall is totally disabled. The Time Capsule is setup to forward traffic on port 80 to the Mac Mini (it's default web server is enabled).

I briefly hosted my own website on my desktop PC back in 2002 but I've never been great with networking. I don't want great performance. I just want to do this for the educational benefit and geeky thrill. And I want a sandbox where I can put my programming and design experiments.

What am I missing? I expected to see the router's admin screen when I hit its internal IP address but I am surprised (and a tiny bit frightened) that I see its admin screen from its external IP address. Should I setup a DMZ (do I give it the router's outward-facing IP?)?

share|improve this question
    
Do you have port forwarding set up on your DSL modem? Is that what you mean when you say the "firewall is totally disabled"? What is the model number of the modem? –  William Jackson Apr 25 '11 at 21:08
    
I don't have port forwarding enabled on the DSL modem. The modem's firewall is set for "No Security (all traffic is allowed)". I've enabled port forwarding on my router for port 80. –  Spencer Apr 26 '11 at 3:45

4 Answers 4

up vote 1 down vote accepted

Look in your modem's settings for something to the effect of "Remote Management" or "Technician Remote Access." Turn it off.

Definitely a good idea to set up a DMZ.

share|improve this answer
    
Thanks. I was surprised to look and see that Remote Administration was turned off. I can't explain that. Nevertheless, I setup the Time Capsule as the "DMZ Host" and enabled Port Forwarding on port 80. I no longer encounter the Admin screen but I am still unable to reach my local web server using the public IP. –  Spencer Apr 26 '11 at 3:44

You might try the guides provided from Verizon about how to setup port forwarding. I found one here: http://www22.verizon.com/residentialhelp/highspeed/networking/troubleshooting/portforwarding/123898.htm

You could also try connecting on a non-standard port. It would at least let you know that the port forwarding is working. To access a non-standard port, put a colon (" : ") followed by the port number to your URL.

share|improve this answer

You may be able to turn off remote management, as ultrasawblade states - and you might want to do this anyway to prevent people from trying to hack in to your router - or you may be able to assign it to another port so that it doesn't clash with your requests to access your Web site (on http default port 80).

Here's the relevant settings on my router:

Router settings

share|improve this answer
    
I was surprised to look and discover that Remote Administration was turned off. I can't explain that. –  Spencer Apr 26 '11 at 3:35

Try accessing your IP address through an external proxy such as proxify.com to see if that makes any difference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.