Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a couple of Linux laptops I have the built in screen never turns off it's backlight, regardless if a 'black screen' sort of screen saver is activated (this both for a laptop running an X-based desktop as well as for a laptop only having a text console) or if I even close the lid of the laptop (looking carefully in the dark, I can tell that the screen still has the backlight on, even if the laptop "know" it is closed).

This is a bad thing for a couple of reasons:

  • It wastes power

  • It generates heat which when the laptop lid is closed increases the cooling need (the fan goes on more often etc).

  • Backlights have limited lifetime like all electric components and IIRC, the less a backlight is turned on, the longer it will last.

So, what is the best approach (considering a Gentoo with a 2.6.36 kernel) to remedy this? I recon that there probably are two approaches:

  • one for text-only laptops which never displays a desktop, e.g a laptop sitting there acting like a firewall or server
  • one for those running a Gnome/KDE/XFCE desktop (and a SLIM or GDM display manager).

The laptops I have in mind is a Dell Latitude CPi (built 1999, yes, it is from another millenea), a Compaq Armada M700 (built 2001) and a Dell Latitude D630.

If this can be accomplished only by configuring things in the Linux OS (be it kernel setup or editing config files) without touching anything in BIOS, that would of course be preferable.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

i'm guessing if its a text only system, vbetool may do the trick. For the graphical system "xset dpms force off" may work, if dpms is set up for the x based system (which would need the option for dpms to be in the xorg conf file)

while its for a BSD based system this might be a good reference to troubleshooting steps

share|improve this answer
    
Thanks for the tip. I'll give the vbetool a try on my 1999 year Dell (once I got it troubleshot for another issue, might take a week or so) and the 'xset dpms force off' option a try on my more modern Dell (which runs X). –  IllvilJa Apr 26 '11 at 14:30
    
vbetool dpms off did the trick with my 1999 year Dell, so now it got a truly black screen, thanks! The same command complains with Real mode call failed on the old Compaq laptop but that's not a problem as I've found out that old laptop actually do switch off the backlight when you close the lid. Only thing left is to try the 'xset dpms force off' on my X-enabled laptop. –  IllvilJa Apr 29 '11 at 11:22
    
I did not get 'xset dpms force off' to work, but mainly for X authentication issues (I logged on to the machine remotely and tried to run the command). So, given that the host were just running as a server (with SLIM being the only application using X) I decided to be brave and use vbetools in spite of recommendations not to use it together with X. So, on that machine I ran vbetools dpms off and the screen went pitch black, without backlight. So, answer accepted! –  IllvilJa Apr 29 '11 at 12:19
    
xset dpms force off works perfectly for me on Arch Linux - and exactly what I wanted. Searching for "linux blank screen" only brings up people who are having problems with blank screens on boot :P –  Wayne Werner Jul 12 '12 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.