Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 on a laptop, and I'm having a bit of an issue with my CD-ROM drive. Each time I boot up my computer, for some reason, that device gets disabled. In other words, I can't access it from Windows Explorer and I can't use it at all.

So far, I've had to fix that each time by opening Device Manager, finding the relevant drive/device in the list, seeing that it is disabled, right-clicking it, and clicking Enable. Having to do this every time I boot is not fun.

Why is the drive being disabled automatically, and is there a way to stop that from happening?

If more specs are necessary for an answer, let me know.

share|improve this question

2 Answers 2

Go into your BIOS and make sure any option to the effect of "Plug and Play OS" is set to Yes. Also, if there is an option to clear anything similar to "Extended System Configuration Data", try it. You might also try resetting the BIOS to defaults.

share|improve this answer
    
Also, if you have any CD/DVD burning software installed, (such as Nero), try a reinstalling it. –  ultrasawblade Apr 26 '11 at 19:45
    
hmm, I've looked in the BIOS and couldn't find anything like that. In fact, I couldn't find anything about the CD drive in the BIOS at all, except boot order, that is. Thoughts? Here's the whole BIOS listing: support.dell.com/support/edocs/systems/late6410/en/SM/bios.htm –  Maxim Zaslavsky Apr 29 '11 at 18:58

I had the same problem: my audio and DVD were disabled even in BIOS. I went in to a repair shop and they told me that my NVIDIA graphic card chip was damaged. They repaired it and solved this problem. Please check your graphic card chip.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.