Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Ubuntu, and Google Chrome mostly. How can I kill these HTTP headers, so that my browser caches this data? I believe it is XHR. Here are the relevant HTTP response headers:

Cache-Control:no-cache, no-store, must-revalidate
Pragma:no-cache

I also have Firefox, is there a plugin or something I can use to not respect "no-cache" ? Thanks

share|improve this question

migrated from stackoverflow.com Apr 26 '11 at 0:52

This question came from our site for professional and enthusiast programmers.

    
So you're trying to grab an mp3 from a site that looks like it specifically doesn't want you to do so? – Marc B Apr 25 '11 at 16:46
1  
Why isn't manually downloading the MP3 file sufficient? – Matt Ball Apr 25 '11 at 16:47
    
I don't have a direct link, that's why I want it to save to my disk. – Matt Apr 25 '11 at 17:10
up vote 2 down vote accepted

Quite universal way might be to set up a local proxy (like Squid), and setting it either to remove that header, or to ignore it and cache the file for you.

share|improve this answer
    
I have installed Squid before.. but I couldn't figure out how to use it. But if you could tell me what to put in the config file [squid.conf?] to ignore [or maybe rewrite] the no-cache header, that would be awesome! – Matt Apr 26 '11 at 15:39
1  
update. I googled around and I found the correct command to put in /etc/squid/squid.conf: header_access Cache-Control deny all – Matt Apr 26 '11 at 16:34

Another lighter solution might be http://www.privoxy.org/

share|improve this answer

As @che mentioned a local proxy like Squid do this.

Edit the config in /etc/squid/squid.conf.

You may work headers using request_header_access see http://www.squid-cache.org/Doc/config/request_header_access/.

In this case request_header_access Cache-Control deny all.

Also have a look at the config for refresh_pattern at http://www.squid-cache.org/Doc/config/refresh_pattern/.

You may find some examples at http://archive09.linux.com/feature/153221.

Then you might want something like Proxy SwitchySharp in Chrome to control proxy settings.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .