Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My computer has Windows 7 (RTM) as an OS and I'm using two monitors.

The power saving settings put the computer to sleep after 30 minutes of inactivity. When the computer wakes up, it always uses only one monitor instead of all two. Always the second one, not the monitor I use as a primary display. So the taks bar, start menu and all icons are moved to this second monitor. The other monitor is just black.

I can restore my preferred dual monitor setting by displaying Control Panel\Appearance and Personalization\Display\Screen Resolution and changing the setting of "Multiple Displays" to "Extend these displays". However, I don't want to do this every time my computer wakes up.

The computer worked fine with the two displays with Windows XP.

Does anyone know if this is a feature or a bug and how to wake up my Windows 7 with both displays running.

share|improve this question
I had this with mine too and gave up in the end. It turned out that my graphics card (ATI 800XT) wasn't compatible with Windows 7. What graphics card is it exactly and do you have up to date drivers installed for it? – Kez Aug 21 '09 at 23:04
I have a GeForce 7300 GT. The driver was pretty new but not the latest version. I will try to update and check if this make a difference. – Murmelschlurmel Aug 23 '09 at 19:16
I updated the drivers, but got the same error today. – Murmelschlurmel Aug 26 '09 at 9:50
Just an update: I didn't find a solution, so I just turned off the set to sleep command. – Murmelschlurmel Sep 16 '09 at 16:40

You can use Windows Task Scheduler for this. Waking from sleep is Event ID 1. So for parameters of your Task use:

  • Trigger: "On An Event"
  • Log: System
  • Source: Power-Troubleshooter
  • Event ID: 1

now for the task to run, you can use Multires. Point task scheduler to the location of multires.exe and use the command-line parameters to reset the display to the same settings it should already be using. Something like this should work:

C:\multires.exe /1:1680,1050,32,75 /2:1680,1050,32,75

This would set both monitors to 1680x1050 resolution @ 32-bit color and 75hz refresh rate. It should trigger the other monitor just as if you changed these settings in the display settings.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.