Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason my week old install of Windows 7 Ultimate x64 RTM can't play .WMV files via Windows Media Player or Windows Media Center. When I double click on a .WMV file, Windows Media Player opens, and says "Media changing" in its HUD. I then get a pop up that reads:

Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file.

If I try to open a .wmv with windows media center it get the following error message:

Windows Media Center cannot find the specified file. Be sure the path is typed correctly. If it is, the file does not exist at the specified location, or the computer where the file is stored offline.

I've tried several .WMV files including the sample .WMV file that come with Windows 7 called Wildlife.wmv. What's even stranger is that the files will play in Zoom Player. I believe this issue was present before I installed Zoom Player however.

Here is what I've tried so far:

  1. Double checked that Windows Media Player is associated with the .WMV extension. I've done this by checking the association menu and right clicking on a .WMV file -> open with and setting the association that way.

  2. Ran sfc /scannow as administrator as per this thread: http://social.answers.microsoft.com/Forums/en-US/GettingReadyforWindows7/thread/bb823460-44df-4e8d-ba2c-42ec0e111e5a

Any ideas would be appreciated.

Edit: Update I just discovered that it won't play .mp3s either, and I seem to remember that it didn't from first boot after install.

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

thanks bro i had the same problem and same sound card and it was driving me crazy, i figured out instead of reinstalling you can just go to sound in control panel and when you click it, it will say its not performing properly do you want to disable enhanced functions click yes to that. Now media centre works fine THANK YOU.

share|improve this answer
    
I like your solution better than mine which was to reinstall the driver. Therefore, I'm changing this to the correct answer. –  Daniel Auger Oct 15 '09 at 17:03
add comment

I believe that recently I read a few comments from friends that installing the Windows Movie Maker currupts many settings and features in Windows Media Player (It is still beta!).

I don't suppose you installed this did you?

I am trying to dig up the article to fix, it involved a hot patch file and a registry fix... if you did not install Windows Movie Maker, please say and I will stop looking!

In addition, as a short term alternative, you can try to install VLC Media player, it should be able to play almost anything you throw at it natively without requiring codecs.... and if there is anything wrong with the file (I know its unlikley) VLC can alert you.

share|improve this answer
    
I didn't install windows movie maker. That is a good suggestion however, and I'm sure others will find it of value if they come across this issue. –  Daniel Auger Aug 21 '09 at 23:25
add comment

I uninstalled and reinstalled my Creative Audigy 2's drivers. That fixed WMP playback. I have no idea why things played fine in other applications. Go figure.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.