Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed proftpd on my server, I tried to connect to the server but I get LOGIN INCORRECT. I have seen the log and I found this:

Apr 26 13:02:39 vmi** proftpd[16738] vmi**.**.com (***[::ffff:...*]): notice: unable to use '~/' [resolved to '/home/lighttpd/vhosts/mywebsite.com/web/']: Permission denied

The permissions of /home/lighttpd/vhosts/mywebsite/web are:

drwxr-x--- 2 mywebsite.com mywebsite.com 4096 2011-04-26 12:04 web

proftpd runs with proftpd:proftpd permissions.

To solve this I added the proftpd user to the mywebsite.com group.

Take a look at /etc/group

mywebsite.com:x:1003:proftpd

So I added proftpd to the group and set RW permissions to /web directory.

I don't understand why I get PERMISSION DENIED.

share|improve this question

1 Answer 1

Did you restarted proftpd daemon after adding user proftpd to mywebsite.com group? If you did not then currently running proftpd process doesn't have that group in it's privileges.

If you however did restart proftpd, then try su to proftpd user and manually enter directory you get permission denied. Maybe you do not have privileges on some higher level directory(ies)...

share|improve this answer
1  
namei -l /home/lighttpd/vhosts/mywebsite/web is a quick way to see if all parent directories have the required permissions set. –  grawity Apr 26 '11 at 21:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.