Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using Firefox since 2.0

I'm using 3.5.2 now and all of the sudden, sites won't load their CSS anymore. Like Google Reader for instance. Or ikariam.org once logged in. All the colors and images you get are those defined in HTML.

I have Opera 9.64 and IE8 on my machine too, and they work just fine.

Example:

Google Reader Screenshot

I had to make this question in a different browser because firefox won't load the code buttons above the textbox anymore... what the hell is going on here?

EDIT: I ended up re-installing firefox. Good thing I use Weave and backed up my addons...

share|improve this question
    
Have you disabled all of your Firefox plugins and tried to recreate this issue? –  jdl Aug 22 '09 at 0:02
    
"Or ikariam.org once logged in." - so it looks OK before you log in? Have you tried clearing cookies? –  Ciaran Aug 22 '09 at 0:04
    
Double check that View->Page Style->Basic Page Style is selected –  hyperslug Aug 22 '09 at 0:05
    
jdl: tried recreating, didn't work. Started firefox in safe mode, still has the problem. –  KdgDev Aug 22 '09 at 0:41

3 Answers 3

up vote 2 down vote accepted

One possibility is that Firefox thinks it has the CSS cached. To tell Firefox to ignore this cache, try hitting Control+Shift+R together. That makes Firefox refresh the page and download everything again (essentially, ignore caching). Hope this works for you.

share|improve this answer
    
+1, my first thought was to clear the cache (not that it always works, but it's quick and painless so why not?) –  David Z Aug 22 '09 at 6:40

click on "View" at the top, go down to "Page style", and make sure that anything other than "No Style" is selected (usually "Basic Page Style")

If this is not the case, make sure you have no firewall or addon that is blocking css files.

It may be a idea just to temporarily disable all add-ons and if that fixes it, re-enable them one by one until you find out what is causing the error.

Lastly, just check general Firefox settings and make sure that nothing is being blocked, or anything set that you think shouldn't be.

It is rare, but it could be that the content is being delivered from a SSL page and you have some sort of error with a certificate, causing content from the secure domain not to be delivered. If the address is not https:// ignore this!

share|improve this answer
    
The page style is working fine and I haven't changed my firewall settings in over a year... –  KdgDev Aug 22 '09 at 0:42

Maybe you have a user stylesheet that is resenting the page's stylesheets

assuming you're in windows. Look into d:\documents and setting\username\application data\mozilla firefox\profiles\random.profile\chrome Maybe the path isn't entirely right (changed mine an I'm telling this from memory) The file is called userContent.css

You installed the stylish add-on? check there too.

Also look for hostperm.1 and permissions.sqlite those two files control the loading permisions for webpages

If it still happens, try moving the profile folder so firefox doesn't find it. Then you can try coping the folders back one by one to identify the one causing problems (a plugin surelly)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.