Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install eUML in eclipse, but I get this error:

Cannot complete the install because one or more required items could not be found.
Software currently installed: eUML2 Free Edition (
Missing requirement: Diagram tools Plugin (com.soyatec.diagrams requires 'bundle org.apache.batik.dom.svg 1.6.0' but it could not be found
Cannot satisfy dependency:
From: eUML2 Free Edition (
To: com.soyatec.diagrams []

It seems that org.apache.batik.dom.svg is missing, but I can't find an update site that has it. How can I fix this error? (I'm running latest Helios on OSX 10.6).

share|improve this question

Also install the GMF runtime and GMF Notation from the update site:

://Indigo -

Then the required bundle will be installed and the installation of eUML will work.

share|improve this answer

I solved the problem in a not so orthodox way. I downloaded the Eclipse Graphical Modeling Framework SDK 2.0 from the archive versions. From my research, I discovered an article about installing Apollo for Eclipse, which is another UML tool. This article indicated the SDK 2.0 version contained the org.apache.batik.dom.svg 1.6.0.jar file.

Once downloaded, I unzipped the file into a holding folder. I then copied the entire contents of the "plugins" folder and combined it into the "plugins" folder in the extracted eUML2 foler. I then placed the eUML2 folder into the "dropins" folder in Eclipse and restarted Eclipse. For some reason it picked up the documentation jar, but did not pick up the other jar file. I then used the "install new software" feature and pointed to the folder in the the dropins folder. It worked, but then came the fun of trying to set it to do what I wanted, which was reverse engineering. Good Luck!!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .