Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to use the front panel eSATA port on my PC case. I remember having to change a setting in the registry to prevent my Boot drive from showing up in the safely remove hardware list (not sure how to revert this, maybe that's the key to my problem..). I have now upgraded my computer (GBabyte P67A-UD4). Even after enabling AHCI mode in the BIOS and playing around with the TreatAsInternalPort settings in the registry I cannot for the life of me get my external hard drive to even show up in the drive list.

However, if I use the native eSATA port physically built into the motherboard, the drive works perfectly but I don't want to have to reach down the back of my PC every time I want to use the drive.

Screenshot of current BIOS setup shown...

P67A-UD4 BIOS snapshot

share|improve this question
Aren't there any... you know, menus? – Hello71 Apr 27 '11 at 0:53
Where, in the BIOS? what you see here is all I see... and if you mean inside Windows 7, yes, yes there are hundreds of menus. – Jay_Booney Apr 27 '11 at 21:13
Are you certain that you connected the extension cable from the port on the case to the motherboard properly? If it shows up when you plug it into the motherboard directly, it's probably not a BIOS setting. Sounds like a physical connection issue to me. – Uninspired Apr 27 '11 at 21:33
I'm pretty sure it's not a physical connection problem. I am using the same case as before with my previous motherboard and it worked then. I've tried re-installing the sata AHCI drivers for the motherboard but still no luck. I'm stuck. When I turn the drive on whilst plugged into the front port, it doesn't even spin up. Could this be to do with the setting regarding the power source? I seem to recall there are two variations of eSATA, which are power and data attached to motherboard, and data cable only with external PSU. Not sure where these settings are located. – Jay_Booney Apr 27 '11 at 22:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.