Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a netbook with an external CD/DVD burner running Windows 7 Starter. Whenever I put any CD or DVD (doesn't have to be blank) in the drive and navigate to its path in Windows Explorer, it tells me under "Files Currently on the Disc":

Files Ready to Be Written to the Disc (1) desktop.ini 23/03/2011

I can't recall ever doing anything that I would've expected would send any files to be written the CD/DVD.

The contents of the .ini file doesn't look suspicious:

[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21815

Is this some Windows 7 feature I didn't know about? A known glitch? Likely the result of some accidental and unnoticed drag and drop? How do I undo it? Is it safe to just delete the desktop.ini via Windows Explorer?

share|improve this question
up vote 20 down vote accepted

Here is what happened:

  1. In the process of a burning a CD/DVD or preparing to burn a CD/DVD, you changed the sort order, arrangement, or other layout/view option for the special "Burn DVD" folder Windows uses as a staging area for these files to be different than the default view.
  2. A hidden "desktop.ini" file is created automatically to hold this information, so that the next time you view the folder it will remember your preference. This is normal behavior for any folder on your file system, and if you go looking for it you can find this file all over the place.
  3. After burning the CD, this file was cleared out along with everything else. However, your layout was still non-standard, and so it is recreated when the folder is closed.
  4. You now have a file sitting in the special staging folder, and that trips up the "File waiting to be burned to CD" notice.
share|improve this answer
3  
An answer that actually explains what causes it. This shoud be accepted. – frostymarvelous Jan 13 '12 at 16:40
    
very good answer quality, I had the same question and it answer it perfectly, thanks you sir :) – happy Oct 17 '13 at 13:38
    
That's great and all, but how do you correct the behavior - i.e. see files that are already on the disk? I tried deleting the ini file and changing the view, neither worked. This is a great explanation but does not solve the problem. – Travis Heeter Jan 21 at 18:13
    
So you visit the folder to delete the ini file. At some point, you'll close the folder and the file is recreated again. Try deleting the file via the command line. – Joel Coehoorn Jan 21 at 19:08
    
This answer is wrong! Desktop.ini is created by Windows by default and does not require changing View layouts. In OP's example it simply marks the folder as a staging area for caching ready-to-burn files, and localizes its name. It can be used to store custom view settings but not in this case, not here. – Vassile Apr 29 at 5:28

The post Desktop.ini file keeps showing up as a file to be written to a blank CD says it is normal behavior. One person suggests hiding system files so you don't see it.

share|improve this answer
    
You get the points for revealing I only see it because I have show hidden files enabled. – hippietrail Apr 27 '11 at 1:03

Ignore it, it's just a file similar to the thumbs.db file you see. It can also be considered the same as the .DS_STORE file found in Macs. It just contains certain configuration for the current directory.

share|improve this answer

Right click on the following folder: C:\Users\Administrator\AppData\Local\Microsoft\Windows\Burn or C:\Users*[your user name]*\AppData\Local\Microsoft\Windows\Burn

Select Properties > Security TAB > Edit > Click on any user name > CHECK: Deny (to the right of Full Control) > OK > OK

Desktop.ini no longer shows up, I don't know what other consequences this will have other than maybe not directly burning to the disc, but most of us use third party burning software anyway.

share|improve this answer
    
Hmm I tried the version with [my user name] and when I clicked on a user name it was also mine. After clicking Deny and OK, the two desktop.ini still show up on my desktop. – hippietrail Sep 29 '11 at 14:57

C:\Users\Administrator\AppData\Local\Microsoft\Windows\Burn

or

C:\Users\<username>\AppData\Local\Microsoft\Windows\Burn

Local doesn't show up; just AppData and then Microsoft with an empty folder when Microsoft is clicked.

share|improve this answer
    
Is this an answer or a comment on Bite-me's answer? – hippietrail Aug 27 '14 at 4:26

I was having the same issue reading a DVD with files burned from another computer. Viewing the DVD would only display a Desktop.ini file with no actual data files. “Ready to Be Written to the Disc” of any CD or DVD inserted under Windows 7.

Solution - Since the system was a laptop, I was able to remove the DVD drive from the bay. After a few seconds, pop it back in which Win7 re-discovered the drive.

Result, the files now appear normally without displaying the Desktop.ini file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.