Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Installed some windows 7 updates today, mostly just optional fixes and it installed an update to my IntelliType or IntelliPoint drivers (Keyboard & Mouse). It asked to reboot, computer gets to the windows load screen and redirects to the repair utility. Repair utility failed, it said if I recently installed a device, unplug it and try to restart. So I unplugged my keyboard and mouse, restarted. Nothing.

I noticed that all the errors seemed to be Windows 7 thinking the installation was on another one of my slave drives. For example, my windows installation is on C:, but I have other drives, like G:, X:, etc... So it said "Critical Boot File G:\Windows\system32\drivers\amdxata.sys is corrupt, but why not C:\ ? So I unplugged ALL other hard drives, it still tried loading X:, even though the only one plugged in was C:

I have the windows disk, but that didn't seem to help. I was thinking I need to fix my boot.ini or something simple like that was corrupt, the hard drives seem fine.

share|improve this question
    
Try booting in safe mode. –  Hello71 Apr 27 '11 at 2:29

3 Answers 3

Hopefully you've got it fixed by now but for anyone else who is looking, I had the same problem. My problem started after a failed install attempt of seagate firmware drivers. Wouldn't boot in safe mode, wouldn't complete a working system restore, etc.. I fixed it by booting from the Windows CD in repair mode and opening a command prompt. It read:

X:\Windows\System 32\

and typed:

X:\Windows\System 32\** bootsect /nt60 ALL

(NOTE: nt60 is for Windows Vista, 2008 or later. If using XP or previous it is nt52)

This will update the boot information for every drive/volume on your computer. If you want more info about it you can type: bootsect /help and it will bring up your options in the bootsect.exe application. After that windows booted up for me with no problems and the phantom X drive had disappeared.

Hope this info helps, certainly scared the shit outta me when it first happened!!

share|improve this answer

You said that even after removing all drives except the main hardrive, it still tried to access X:

So:

  1. Either in the BIOS boot, you have disabled booting from C:.
  2. Your C:\ harddisk has bad sectors.

Try downloading SeaTools from SeaGate (Tool to detect hard drive failure), burn the ISO to disk and boot using the tool.

Run the tool and if it says that the hardisk is corrupt, its time for you to buy a new harddisk.

BUT: You said on the login screen, it says "computer gets to the windows load screen and redirects to the repair utility". Means that Windows is loading. In that case start with "Safe Mode with Networking" and see if the machine is booting. if yes, try disabling the driver for IntelliPoint and reboot.

OR The boot partition is on one drive and the Windows 7 installation is on another. So the machine detects that there is Windows Installation somewhere but when it trys to boot it fails since the Windows installation or the HD is corrupt.

share|improve this answer

I've just ran into very similar problem. The only thing is - windows folder is still on "C" drive, as it should:

C:\Windows\system32\drivers\amdxata.sys

Here's what I've tried without any luck:

  1. Reboot several times
  2. "chkdsk C:" (no problems detected)
  3. "bootsect /nt60 ALL" (as suggested)
  4. "sfc /scannow" (which resulted in "Error :There is a system repair pending which requires a reboot to complete.", just as discussed here. Though, I've not tried "dism.exe /image:C:\ /cleanup-image /revertpendingactions" hint)

The thing that worked for me was simply to replace those "damaged" file with "correct" one. By the way, it's really damaged - it's made of 26992 bytes, and they all are equal to zero. Moreover, I've found the "correct" file in the same directory, under "amdxata(56).sys" name. Probably it's a sort of a backup.

There's a lot of methods to copy this file, starting from booting some temporary OS from a flash drive, or simply connecting your OS hard drive to another PC, whatever is simpler in your case.

PS: I've also posted the same info here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.