Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
While editing a document in Word 2007 the document suddenly becomes read only

This is really annoying. When I work on a Word or Powerpoint document in MS Office 2007, after a while, the document becomes read-only by itself. As to how I learn this: When I try to save the document by clicking the save icon or using Ctrl+S, the "save as" window opens (this should not happen, the file should be saved directly). I select the same file name and try to save, but MS Office says (roughly):

Word cannot save the file. The file you want to save is read-only.

When I look at the file name at the top of Word window, "Read-only" is written next to the file name.

As a one-time solution, I save the file with a different name, and delete the previous (read-only) one. Then I rename the file to preserve its name.

I made an extra test: When the Word doc became read-only, I directly closed it without saving. Then I re-opened it, and it was NOT read-only. This is strange.

This happens with Word and Powerpoint, and it happens after some time of work. The computer does not sleep/hibernate in the meanwhile. I'm admin on that machine.

How can I fix this annoyance?


UPDATE:

I talked to the I.T. department. They told me they have received complaints from some other users on this issue and tried to solve this. So far, they couldn't find the reason and an exact solution. They also said this is not related with the network; this is a problem in MS Office.

CLARIFICATION DERIVED FROM COMMENTS:

  1. The files are local and located on desktop and in "My Documents" folder. None of the folders on the PC is shared over the network. According to my experience so far, it happens to every MS Office file no matter where the file is located in the HDD after a certain period of time (after 15 mins, 30 mins, etc.). I googled this problem and I found out there are people having the same problem, but there is no answer.
  2. This PC is on a company domain and our IT department's policies don't let us disable the AV software.
  3. To-do: Create a new folder, put a word file there and then press Save several times. Does this "Read Only" bug appear or does it only appear once in a while? (Test result: No effect. It only appears once in a while)
  4. To-do: Clean the temp folder.
  5. I don't use any third party search tools like Google Desktop; so the problem is not related to file locking due to search indexing.
share|improve this question

marked as duplicate by Moab, random Sep 23 '11 at 14:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Does it help to turn off the detailed view in your file view? –  Xenoactive Aug 1 '11 at 0:47
    
Any updates on this? –  TeX HeX Aug 13 '11 at 11:41
    
AV software scans the document when you open it, sometimes it does not release its handle on the file, leaving it in read only status, disable AV software to verify this. –  Moab Sep 12 '11 at 19:24
    
@Moab: Please read the clarification #2 in the question. –  Mehper C. Palavuzlar Sep 12 '11 at 20:18
    
I guarantee AV is the problem, that is why your IT cannot figure it out. –  Moab Sep 12 '11 at 20:24

6 Answers 6

In my experience this is usually caused by a lack of permissions in the folder that the files are stored in. Take ownership of the folder and give your username full permissions in that ACL.

Here is a link to microsoft's technet site on how to set permissions and take ownership. (for win 7) http://technet.microsoft.com/en-us/library/cc770962.aspx

share|improve this answer
1  
He says that he can close the file, re-open it, and it's not read-only. I'm not aware that ACLs come and go. –  Xenoactive May 11 '11 at 1:10
1  
Epic Fail. If it is read only, then you CAN open and close the file. Read only mean you LITERALLY can ONLY read it. Try it. –  surfasb Jun 23 '11 at 8:25

This sounds vaguely like the "file in use" problem that I've read been reading about: http://support.microsoft.com/kb/942146/

share|improve this answer

See if you can open and save other types of files, using Notepad. That will narrow down the cause. It's unlikely that it is an Office app only issue. While unlikely, are your folders redirected? You can tell by checking under properties. Redirected folders look like they are rooted on your local drive, but they show up as a network link under Folder Properties.

Edit: Also, you don't happen to be connected to a Sharepoint server?

share|improve this answer

I have seen cases where people have used Outlook to store the files. Whenever you leave your temporary files unattended to, the temp files can get a bit overwhelming. If you're always editing a document with the same file name, there is a limit of 100 or 200 temp files with the same file name. I would look to see where the files are being saved to (temp folder) and clean that out.

share|improve this answer

I am experiencing the same problem. I found this.

From: http://www.contextures.com/xlfaqapp.html#ReadOnly

All of a sudden a number of my Excel 2000 files have become "read-only".

Clear out c:\windows\temp directory on the machine that houses the files, then reboot.
share|improve this answer
    
@ Mehper C. Palavuzlar, Please follow up on this answer. –  Moab Sep 12 '11 at 19:26

I would check for any processes like a virus checker or a network backup. Any process that accesses the file will fool office into thinking it is being shared, and thus revert it to read only until it can gain exclusive access again.

share|improve this answer
1  
Just because IT says it's not the network, that doesn't mean it's not the network ;) –  Joel Coehoorn Jul 28 '11 at 22:08

protected by random Aug 2 '11 at 21:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.