Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wonder if you can help me out.

I am trying to connect a Dell Latitude D410 to a WPA-PSK wireless network which uses AES data encryption. The laptop has Windows XP Pro 32 Service Pack 3 bit OS installed.

It seems to connect ok for a few minutes, and then I will get a notification telling me that it has connected to the wireless network again. Shortly after that it will display the message unable to connect to preferred wireless network.

If I install Windows 7 Pro 32 bit on the same laptop, I can connect to it with no problems?

The laptop is being used in an office and I regularly test other laptops on the same wireless network all which have no problem connecting. We have a network engineer who has assured me that all the network equipment is fully tested and working absolutely fine. We connect all the PCs to our domain, but these issues occur before I connect it to the domain.

I have formatted it twice with Windows XP and same issue occurs each time.

I have even tried using another 3COM wireless card to see if it is the hardware itself, but it also gets disconnected too.

The problem seems to be something that is part of the hardware for that particular laptop. I suspect it may be something to do with the built in Bluetooth.

The last thing I haven't tried yet it to totally disable the wireless in the Bios and see if it lets me use the 3COM card.

Any help or suggestions would be very much appreciated.

share|improve this question

migrated from serverfault.com Apr 27 '11 at 9:41

This question came from our site for professional system and network administrators.

add comment

1 Answer

You have buggy drivers for your wireless card. Try updating the drivers, or replace the card with a newer one.

My reasoning:

  • The card may be the fault, but you've tested it under Windows 7.
  • The OS may be the fault, but Windows XP SP3 supports WPA-AES properly.

The only other thing I can think of are the drivers. The Dell website has drivers for your system. You will need to know which card is in your laptop (look at the label on the bottom of the laptop, or check Device Manager for the model number), then download and install the latest driver - EVEN IF the one in Device Manager says it is the same age or "newer."

You might have installed a generic driver from Windows Update, or such, or the driver files may be damaged. Install the proper driver from Dell and see if that helps. If not, you can always pick up a USB WiFi adapter, a Mini PCI adapter, or take it to an authorized repair center and have them replace your card with a newer model.

I hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.