Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having an ongoing issue when trying to start up games. I have my various games pinned to my taskbar, and sometimes, when I try to click on them to start 'em up, the icon lights up for a moment, but then fades and the program doesn't start.

If I go into my task manager, a process is running for each one, but the programs don't actually start.

It doesn't seem to happen with any specific amount of frequency, so I'm not sure what the cause is. Any ideas as to where I could begin troubleshooting this problem?

Operating system is Windows 7.

share|improve this question

migrated from gaming.stackexchange.com Apr 27 '11 at 14:17

This question came from our site for passionate videogamers on all platforms.

1  
If you can give us some more information, we might be able to give more specific help ... which OS are you running? Are these Steam games? What games have problems? (If you have 20-30 games, no need to list them all, I'm just wondering if there is something they have in common.) –  Dave DuPlantis Apr 23 '11 at 2:35
    
And some history would be nice, too. When did this start happening? Can you tell us what you did since then? Like installing new software, or updating a hardware component. –  Bora Apr 23 '11 at 10:52
    
Here's what info I have - the OS is Windows 7. Specifically, this issue started occurring after I upgraded from Windows Vista to Windows 7 and started using a new solid state drive as my boot disc. It tends to happen with just about anything I try to run, be it Steam or WoW or Spiral Knights or whathaveyou. My concern is I may have a bad solid state drive, but I don't have any knowledge on how I'd go about verifying/rectifying that. –  Alex Swift Apr 23 '11 at 12:17
    
Was your upgrade a clean install, or an upgrade within windows keeping your data? Have you tried 're-pinning' the games to the task bar? Maybe they arent in the same location as when the shortcut was made. Also, will the games open if you manually run the exe? –  AkkA Apr 23 '11 at 14:54
    
This was a clean install of Windows 7 on a brand new solid state. I haven't yet tried running the .exe files directly when the problem springs up, but I'll give it a shot. I'm confident the pinned shortcuts themselves are pointing to the correct location, because they work a good portion of the time. Will update next time it happens to see what I can uncover. –  Alex Swift Apr 24 '11 at 9:52

1 Answer 1

The most probable reason is that the corresponding programs are unable to display any error message.

To check this, you could open a command prompt, change the current directory to that of one of your games and invoke the executable file manually. The location and name of executable files should probably be available from some 'properties' contextual menu item or configuration panel in your menu bar.

Running the binary files from the command prompt might produce some error message.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.