Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a bit of trouble with a HDD. I believe it's dead and I plan on RMA'ing it tomorrow, but I thought I should just check up here first to make sure there are no other options.

I posted a similar question on askubuntu.com two weeks ago but as yet I haven't got an answer that helps. I don't intend to spam this question all over the place but I feel it's a legitimate question for SU as I believe it doesn't particularly deal with Ubuntu or *nix in general.

Initially the HDD was just acting in an odd way. I could change permissions, etc. but some files were being missed and I wondered if some of the sectors were failing. This progressed to complete drive failure. It wasn't detected during POST and a look in BIOS didn't turn up anything.

I switched it to a different SATA port and to my surprise the drive worked again. I concluded that the SATA port was defective. But then after another week or so of use the old problem recurred. Odd behaviour when setting permissions, followed shortly by total failure.

I again switched SATA port. This time I switched to a JMicron controller. (I have Intel, JMicron and Marvell SATA controllers on this particular board.)

The drive isn't detected during POST.

Is there anything at all I can do? It's formatted as ext4. I wonder if changing the location of the superblock might help?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

That the problem followed your drive when you switched to a different SATA port suggest the problem lies past the SATA port; that the drive functioned fine after the switch but then gradually failed again, and now won't function on a different port/controller entirely, suggests to me that the most likely culprit is the SATA cable itself. I'd recommend replacing that (they're dirty cheap anyway) and see if the problem goes away.

Also ensure that said SATA cable is fully seated. (I had a hard drive just the other day fail on me, to the point that the system couldn't read the 'shutdown' command from the disk and I had to hard kill it, and it turned out the SATA cable had simply been unplugged when I had closed up the case. Plugging the cable back in immediately fixed the problem, naturally.) Finally, make sure you don't have any fans chewing on that or any other cable (I've lost at least 2 SATA cables, an IDE cable, and even a floppy cable that way, not to mention one fan chewing apart its own power cable!).

If reseating and replacing the SATA cable don't fix the problem (also try different power cable, might be an issue there), then the issue might indeed be a faulty hard drive. One last thing to try would be to put the hard drive in place of an existing good hard drive (preferably in a completely different computer, if possible) and see if the problems persist -- if they do, that's a strong indicator that the hard drive is at fault.

share|improve this answer
2  
I really recommed cable ties... –  Turbo J Apr 27 '11 at 17:28
    
alternative to trying different ports/cables/computers an external USB-to-SATA/IDE adapter/connection can be useful for trouble shooting hard drives too –  Xantec Apr 27 '11 at 17:34
    
thank you a million times! It was a crappy SATA cable (properly seated). Altho' I have a back-up of all those files, they're distributed around the world and it was going to be a huge pain to get them all again. I never would have thought that a faulty SATA cable could interfere with how successful a chmod command would be (i.e. some files getting their permissions changed, and others not). Really, I can't thank you enough for this and a simple +1 doesn't even come close. –  boehj Apr 27 '11 at 17:52
    
@Turbo That's how I solved my problems, yes. I used to think they were silly, now I think they're essential!! @boehj It is really odd how failures manifest sometimes, isn't it? I suspect what you saw was a lose connection of some kind in the SATA cable, and the vibrations of the hard drive itself were causing that connection to intermittently break, making your system only intermittently unable to chmod files, but without realizing it was having problems. In my most recent example, the case only partially unseated my cable, and the HDD's vibrations knocked it all the way out. –  Kromey Apr 27 '11 at 17:57
add comment

Modern drives store some infos on the platter surface. They try to read in upon power up, when this fails they will not be detected correctly anymore. One can usually hear the sound when its repeatedly trying to position the heads: The click-of-death.

Failing sectors should leave traces in the HDDs smart protocols (use smartmontools). But that is not available once the disk is broken enough not to be detected in POST, sorry.

For cable problems, see other answer...

share|improve this answer
    
Try the freezing method... It can sometimes allow the drive to read enough to post and be mounted. –  Chris Nava Apr 27 '11 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.