Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows XP, my .txt file association has no icon. It is quite annoying, and has been going on for several months now.

I've tried to un-associate it using the folder-->options--file types, I've tried to change the association, delete the icon cache, and even tried using ftype and assoc. nada.

Any help is much appreciated!

share|improve this question

1 Answer 1

up vote 10 down vote accepted

If you've lost your file icon, you can put in another one or find the old one.

First, open up Windows Explorer, then:

Tools > Folder Options

Scroll down to the relevant file extension, in this case, TXT. Select and click Advanced.

The Edit File Type dialog will pop up.

icon settings

Click on Change Icon...

If you want to find the system default for it, try this location first (edit as necessary for your Windows directory):

C:\WINDOWS\system32\shell32.dll

If you would rather another icon, maybe one you've dowloaded, just navigate to it by clicking on Browse... and opening up the folder.

Click OK to save the changes.

The filetype will now show with the changed/reverted icon just selected.

share|improve this answer
1  
It's a nice and detailed guide for newbie to set the icon in windows. –  deddebme Aug 22 '09 at 5:34
    
This didn't fix my problem, but may fix others' –  Ben Baril Aug 28 '09 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.