Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem:

Need to disable hibernation ( or enable Wake On Lan/ pattern ) for backup routine.

Issue:

Computer does not respond to WOL or any type of network requests. Also, hibernates regardless of NIC or power settings.

Specs:

Model: Dell Opti 780
NIC: 82567LM-3 Intel

What I've Tried

  • Wake On LAN and Wake On Pattern enabled in NIC configuration.
  • Low Power Mode disabled and Remote Wake Up enabled in BIOS
  • High-Performance power scheme with everything set to "never".
  • powercfg.exe /hibernate off. Also, -h off
  • Sleep set to never.

There used to be a simple, easy to find checkmark in XP that said 'enable hibernation'. One could uncheck it and be done with hibernation. Apparently, someone in Redmond ( or maybe at Intel ) disliked the ease-of-use factor of this idea and decided to make it pure hell to disable hibernation or enable WOL in Win 7.

share|improve this question
    
WoL has very little to do with Windows and a lot to do with your BIOS/NIC settings. –  squircle Apr 27 '11 at 21:38
    
Low Power Mode needs to be off for WoL, IIRC. –  afrazier Apr 27 '11 at 23:46
    
I agree with that. I have set the NIC and BIOS settings for WOL but maybe Sane ( below ) is on to something. No hibernation will solve this as well. The hibernation settings are more obscured and klutzy in 7. –  Bubnoff Apr 28 '11 at 0:12
    
@afrazier -- I did that. Still no luck. –  Bubnoff Apr 28 '11 at 0:14

3 Answers 3

  • Is there a Layer-3 switch between the client computer and the computer sending the WoL packet? If you have a layer-3 switch then look into setting it up to pass magic packets.

  • Are you using the correct WoL tool for your NIC? Some NIC vendors use a differently formatted magic packet then other vendors.

share|improve this answer
    
Those are both good possibilities. I think at this point -- disabling hibernation is the easiest solution. I think I may have overlooked a setting somewhere. –  Bubnoff Apr 27 '11 at 23:54

Type "edit power plan" into your Start menu. When you're in the Edit Plan Settings window click on Change advanced power options and you can find this:

Power options

share|improve this answer
    
Have done this. 'Hibernate after' is not there in this stations sleep settings. Could be because I've run the powercfg.exe /hibernate off? –  Bubnoff Apr 28 '11 at 1:27
    
Yes, that's why. Missed that you already tried this. –  Louis Apr 28 '11 at 1:55

On my Windows 7 machines in am using WOL fine with LogMeIn. The settings that I always have to do are as follows. These were the settings we used on our Dell OptiPlex 780.

Bios Lower Power Mode - OFF Onboard NIC (PXE/Other)

NIC Settings WOL enabled uncheck allow to sleep PNE Enabled

I did have to change it a little when we upgraded to the Dell 7010 as the options changed. There was an additional option Deep Sleep Mode in the bios that had to be disabled.

I know you have some of this... thought I would just add our settings. Hope something helps

You can also use the following to make sure your machine is compatible with WOL:

Note: This test will only work on Windows based systems. If you are unfamiliar with working with the command line, please seek further assistance from your administrator.

  1. You will need to save the woltest.exe file http://lmine.ws/hkCYAV to the computer you're going to wake (the computer cannot be asleep at this time).

  2. Open a command prompt and navigate to the directory where you unzipped the woltest.exe file.

  3. Enter the command: woltest -info and press Enter. You should be presented with information.

  4. Take note of the MAC address, Local IP, and subnet mask.

  5. Sleep the first computer, move to another Windows PC on your LAN, and copy the woltest.exe file there also.

  6. Open the command prompt and navigate to the directory where you unzipped the woltest.exe file.

  7. Enter the command: woltest -wake -mac (the noted MAC address) -ip (the noted IP) -subnet (the noted subnet) and press Enter.

Example of the wake command: woltest -wake -mac 00:0c:20:1c:51:29 -ip 192.168.1.142 -subnet 255.255.255.0

This should wake the first computer up. If it does not, your system is most likely not compatible with Wake On LAN.

share|improve this answer
    
Thanks Renee - I will look into this. Sounds promising. We are on the 7010s and I hadn't noticed the deep sleep setting either. –  Bubnoff Jun 4 at 16:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.