Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a WRT54GX2 SRX 200 router, which until a couple of weeks ago, was working happily, until one day it started to disconnect my network from the internet, and today I realized that its internal clock is now on Jan. 1st, 2000. I was at the router dashboard when I realized that but the dashboard said that the date could be configured in the Setup tab, but when I went there, I found no place to setup the date. I'm using Firmware Version: 1.01.22 and Loader Version: 1.00.05 by the way, which are the latest I have found.

I'd like to try setting the date to the current, and see if it stays connected, I understand that date goes in every packet so it could be the cause of the connection reset from time to time.

share|improve this question

My guess is that there probably are a backup battery inside that has run out.

So try to open the device, find the battery and change it.

share|improve this answer
    
but, isn't that the reason why the clock was lost? do you think changing the battery will restore the clock to the current time? I don't think so. – Eugenio Miró Apr 28 '11 at 14:04
    
A lot of devices sync time with a ntp server, and therefore disables the possibility to set it manually. – Johan Apr 29 '11 at 6:52
    
but this won't depend on the battery, right? it only needs to be turned on... or I'm wrong? – Eugenio Miró Apr 30 '11 at 14:10
    
I think the battery is why you lost time, and I think ntp is why you can't set it manually. Two different things. – Johan May 1 '11 at 10:04
    
so both of them are not working then... I can fix the battery but not NTP – Eugenio Miró May 3 '11 at 2:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .