Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Logitech Windows keyboard and I want to use it on my iMac. The problem is that many buttons are mapped to the wrong places. For example, when I press Right Alt + 2 I get the ™ symbol and not a @ symbol. The problem also exists when I'm running RDP and log on a Windows XP machine. I have Swedish regional settings (input method) on Mac OS X.

  • Is it possible to remap the keyboard so that on a remote Windows XP machine all keys on the keyboard really work?
  • Can I disable all Mac OS X shortcuts when I'm in an RDP window?

I have a standard Logitech Windows USB keyboard.

It seems to be a layout problem. When I install the Logitech keyboard layout I can choose it, but it just shifts back to the default layout after a while.

share|improve this question
    
it's not about "wrong mapping", it's more about that mac os is using another key layout, but don't know if there are any tools to remap them. –  schöppi May 12 '11 at 20:40
    
Try using the Shift key to obtain the alternate key function instead of Alt. However, this doesn't solve the re-mapping problem. It is easy enough to re-map keys using software, but the symbols on the keyboard will be incorrect. –  Jay_Booney May 12 '11 at 20:41

4 Answers 4

up vote 6 down vote accepted
+50

You might have a look at Ukelele, a free Mac OS X Keyboard Layout Editor :

Ukelele is a Unicode Keyboard Layout Editor for Mac OS X versions 10.2 and later. Version 2.0 and later are only for Mac OS X versions 10.4 and later.

Beginning with version 10.2 (Jaguar), Mac OS X supports an XML-based format for keyboard layouts (.keylayout files). These may be installed by copying them to the Keyboard Layouts folder within /Library or ~/Library; then they are enabled via the Input tab of the International (Language & Text in 10.6) module within System Preferences.

However, modifying keyboard layouts—let alone creating entirely new keyboard layouts, such as for a new script—by directly editing the XML text is tedious and error-prone.

Ukelele aims to simplify keyboard layout editing by providing a graphical interface to .keylayout files, where the desired characters can simply be dragged onto keys as needed. (The Character Palette or Character Viewer, available in the Input menu if it has been enabled in System Preferences, is a great place to find the characters.)

In addition to simple assignment of single character codes to keys, Ukelele can assign multiple-character strings and can create "dead keys", where a keystroke sets a new state that modifies the output of the following keystroke.

For more information about Mac OS X keyboard layouts, as well as existing layouts available for download, see Input Resources. For some types of layout, particularly with large numbers of dead-key sequences, creating a layout with the text-based tool KeyLayoutMaker may be a useful alternative.

image

share|improve this answer

You might try under system preferences / language & text / input sources. I see, for example, "British" and "British - PC" as separate categories. Selecting the latter seems to cause keys to map correctly to my British (Logitech) PC keyboard. This is after installing the Logitech Device Manager (with no visible effect) and headscratching over the contents of Library/Keyboard Layouts. This in on 10.8.3, for what it's worth.

share|improve this answer
    
This fixes some key but breaks others. My \ is now set incorrectly. Better than have @ wrong incorrect though. –  Will Calderwood Sep 9 at 10:50

The problem is that your modifier keys are incorrectly set. You can fix this by going to System Preferences > Keyboard > Modifier Keys. Change the settings around until you get the correct configuration for your keyboard.

enter image description here

share|improve this answer
    
This answer does not apply to the specific example that is part of the question. If the user is bothered by this, he didn't mention it. –  Daniel Beck May 13 '11 at 6:41
    
I have tried that before, but that dose not fix other key problems. –  Amir Rezaei May 13 '11 at 6:46

System Preferences > Language & Text > Input Sources includes many PC layouts, and there are also premade PC layouts for languages like German and French.

You can use Ukelele to create your own keylayout:

  • Select File > New From Current Input Source.
  • Change the keys.
  • Save as bundle to /Library/Keyboard Layouts/. Keyboard layouts in ~/Library/Keyboard Layouts/ can't be selected in password dialogs or the login window, and the popovers shown when holding keys don't work with normal .keylayout files.
  • Log out and back in and enable the input source in System Preferences > Language & Text > Input Sources.

To apply changes to a keylayout, you have to for example run sudo touch /Library/Keyboard Layouts/ and log out and back in. You can disable the default input sources by editing the com.apple.HIToolbox plist.

Another option is to use KeyRemap4MacBook:

You can add new settings in private.xml. See the source for the predefined settings and key code values.

Or if you can consider switching to the U.S layout, it has all ASCII characters in the same positions on Mac and Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.