Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The date to my computer goes back to 2005 after every restart, what could be the problem?

I have checked the CMOS battery and it is working fine.

OS is Windows XP.

share|improve this question
5  
How did you check your CMOS battery? Tried putting in a new one? –  Apache Fan Apr 28 '11 at 8:16
    
Have you checked to see what date is set in your BIOS? –  Joseph Redfern Apr 28 '11 at 10:37
    
yes i have, it is not 2005 but as of today it is reading 4/28/2011 –  Gatura Apr 28 '11 at 11:18

3 Answers 3

This issue seems to have been experienced by other people, see here and here. No solution given though.

some troubleshooting tips:

  • Is it correct that, just like in the link, it is only the year that changes (with month and day remaining correct)?
    In that case, I'd say it can not be the battery. Moreover, you say you checked your battery, so I would rule out the battery as the cause.
  • As you say the date in the BIOS is correct (again a strong argument for ruling out the battery), the date must be modified during or after booting Windows XP. In that case it must be
    • (a) because of an issue in either Windows XP itself, or
    • (b) caused by some program you installed (intentionally or not), or
    • (c) a wrongly configured NTP server that Windows uses to update the date and time.
      Edit: following grawity's comment below, reason (c) seems not possible.
  • I think reason (a) is unlikely, so I'd rule that out initially.
  • To check if it is because of reason (b): set the correct date and then restart in safe mode (without networking support), and see if the date is changed to 2005. If not, I'd say some program (perhaps recently installed) changes the date.
  • To check for reason (c), go to the adjust date/time dialog box (e.g. double click the time in the task bar) and disable Internet time synchronisation (see here for some dialog boxes).
  • If only reason (a) remains, perhaps you can try changing and resetting the date format in the regional settings (see this microsoft article)
share|improve this answer
1  
Re (c): By default, Windows will not adjust the system clock if the difference is more than 15 hours. –  grawity Apr 28 '11 at 12:12

I have installed AVG anti virus and changed the time server to time-a.nist.gov.

This works at the moment, but I will wait to see how it progresses.

share|improve this answer
    
This worked for a while but then stopped working –  Gatura May 6 '11 at 8:24

The problem was actually coming from the novell server, whose date was set to 2005 so when a user logs into a machine, it picks up the novell date which is 2005. Problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.