Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hoping someone can help here, this is driving me insane.

Outlook 2010 keeps losing the search index so when I search for an email it has the yellow bar saying:

search results may be incomplete because items are still being indexed

Clicking on the bar says eg:

49200 items remaining to be indexed

If it makes any difference, this is an IMAP account. If I leave Outlook open all day it will eventually index everything. But then say a week/month later it happens all again.

share|improve this question
1  
I have the same problem w/ Outlook 2010, but w/ exchange instead of imap. Rebuilt PST files, reset search, the whole nine yards. Search on Outlook is CRAP. –  andersoj Dec 28 '11 at 22:26

1 Answer 1

Hopefully one of these steps will help solve the problem. Source: http://www.msoutlook.info/question/47

There are a couple of levels at which Instant Search in Outlook 2007 and 2010 can break. You can troubleshoot Instant Search in the mentioned order in this article.

Marked for indexing First let us check if the pst-file has been marked to be indexed. To do this go to; Tools-> Options-> Search Options… In the Indexing section you can select which data file to index.

When you are using Outlook 2010, you can do this via; File-> Options-> section Search-> button Indexing Options…-> button Modify-> expand Microsoft Outlook In the list that is shown under Microsoft Outlook, make sure that your pst-file is displayed and selected. If it is not listed, you’ll have to recreate your mail profile.

Locations selected to be indexed in Outlook 2007.

Check for pst-file corruptions If your pst-file has been marked but Outlook doesn’t display the correct results, it usually means there is some corruption going on in your pst-file. In order to fix these you should scan your pst-file for errors with scanpst.exe. You can find this file in the same folder as outlook.exe or use OutlookTools (free!) to locate it for you.

Once repaired, open Outlook and leave it idle for some time. To see if everything has been indexed now go to Tools-> Instant Search-> Indexing Status. For Outlook 2010 you must click in the Search field in order to make the Search Tools tab visible in the Ribbon. Here click the Search Tools button and select the Indexing Status…

When you have a big pst-file this indexing could take some time but if the number of items left to index doesn’t change after leaving your computer idle for over 30 minutes something is wrong still.

Disable and then re-enable the file for indexing Go back to the Search Options and deselect the data file that is giving you issues. Close Outlook and wait for about 5 minutes and also verify in Task Manager (CTRL+SHIFT+ESC) that on the Processes tab the outlook.exe process actually quits. You might get a lot of disk activity; this is the Search Indexer removing the indexed items from the Index.

After this open Outlook again and go back to the Search Option and select the pst-file we just deselected. Leave the computer idle again and see if it will eventually reach the status of "0 items remaining."

Rebuild the index If it doesn’t, it might be that the Index itself has been damaged. In order to reset this, go to Control Panel-> Indexing Options-> Advanced-> button Rebuild

This will rebuild the entire Index from scratch and depending on the amount of documents to be indexed, this could take quite long and degrade your system’s performance while the Indexer is still busy. I would recommend to have it rebuild itself overnight.

Advanced Indexing Options in Windows 7.

Reset the index If it still doesn’t work press the “Restore Defaults” button that you can find under the Rebuild button in Windows Vista. The difference with Rebuild is that, aside from resetting all customized indexing settings like indexing location and file type selections, it will recreate the actual Index files as well.

In Windows 7, you can press the blue “Troubleshoot search and indexing” link. This will start a troubleshooting wizard in which you can select the option “E-mail doesn’t appear in search results”.

Check Event Viewer and post in the newsgroups Still running into indexing issues? It might be good to take a look in the Event Viewer and look for any errors logged by the “Search” or “Microsoft Outlook”. If the error logged there is not helpful to you, post it in the Outlook newsgroups together with your configuration details in order to help you troubleshoot it.

share|improve this answer
    
Thanks, but this didn't help. Just lost it again after a month or so. –  Marcus Nov 27 '12 at 18:37
    
Oh... bugger maybe there is a more deep seated problem like clean-up software being a bit overzealous or just a problem with Windows (need a clean install) or hardware (may need new hardware). Could also just be a different problem, you would need to try and find out exactly when this happens or why or if it always happens after a certain action? –  CodeBlend Nov 28 '12 at 10:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.