Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable the OSX keychain password prompt? This machine is our local build server (running hudson). Everytime the automated build script runs code signing, the keychain pw prompt pops up and halts everything.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Always allow access to that keychain item when asked.


Open /Applications/Utilities/Keychain Access and make sure that the keychain containing the relevant item(s) is unlocked, and will not lock automatically by selecting Edit, Change Settings for Keychain....

share|improve this answer
    
Thanks! side note: Edit->Change Settings for "System" Keychain is always greyed up (even when unlocked). To change the settings for the System keychain, you need to Right click on keychain -> click "Change Settings for Keychain "System", then Disable Inactivity & Sleep Lock. –  John2496 Apr 28 '11 at 14:38

You can remove the "Lock after X minutes of inactivity" setting with the following command:

security set-keychain-settings ~/Library/Keychains/login.keychain

Note that if Keychain Access is open when you run this command, you'll need to close it and reopen to see the change in the keychain settings dialog.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.