Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When trying to input danish characters æøå into vim, I suddenly get "æ ø å " and then the questionmark blocks on reopening. The same goes for files saved in other editors and reopened in vim. I have set my encoding to utf-8 in my vimrc, and experience no issues in other editors. Are there other encoding options I should be aware of than

:set encoding

?

share|improve this question
    
What fileencoding is being set when you open the file? –  grawity Apr 28 '11 at 16:13
    
I have the same problem. –  Remonn Jul 4 at 8:03
add comment

1 Answer 1

You may have to enable detection for UTF-8 by setting fileencodings:

set fileencodings=ucs-bom,utf-8,cp1257,latin1

(note: fileencoding is current, fileencodings is list of encodings to try.)

share|improve this answer
    
I have the same problem as Santeh. Unfortunately your solution didn't work for me. –  Remonn Jul 4 at 8:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.