Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a portable Iomega 250GB HDD. It worked wonderfully for years and passed its warranty period a long time ago. It then started acting up and finally didn't work any longer. The odd thing is that the drive would power up and I could hear it spin, but the computer would not connect with it.

On the advice of a friend, I removed the drive from its casing and tried unsuccessfully to set it up as a slave drive to recover the information on it. It would seem that the Iomega casing had an on-board chip which I am guessing contained the FAT32 (???) information for the drive. I am guessing that this is why my computer will not now recognize the drive so that I can read from it. I have a TON of important backup information on this drive and the drive seems to be otherwise working correctly.

How can I get around any chip or preset information that might have been part of the drive case?

share|improve this question

Unlikley that the case had any "chip" or device that would limit access. Were the jumpers set correctly? Slave or possibly cable select. Perhaps the drive is bad? Have you tried installing in a different enclosure?

If drive issues, try putting it in a ziplock style bag and putting it in the freezer for several hours/days. Remove and immediately connect. Has worked for me many times.

Good luck.

share|improve this answer
The hard drive in question is a: Iomega® HDD 250GB USB 2.0/FireWire® External Desktop Hard Drive Serial Number: 1LFE4500EU I am looking at the case at the moment and there is definitely a board in the case containing several chips. Mini ribbon cable and fan, along with power supply and USB ports. When I connect it to my PC as a slave, it powers up fine and spins. But computer does NOT recognize drive and asks me if I want to format the drive. That is why I thought some of the drive information must be on the case board. the drive is 3/4 full so I do NOT want to format it... – Matt Apr 28 '11 at 14:59
Also... HD inside the Iomega is a Western Digital WD Caviar SE Enhanced IDE HD P/N WD2500Jb For what it is worth – Matt Apr 28 '11 at 15:20
Further follow up: I just used a USB to IDE/Sata cable to connect the drive to my laptop. Again the same results. computer recognizes drive. Breifly goes thru setup then tells me that I need to format the drive. How do I get to the information? – Matt Apr 28 '11 at 15:43
@ Matt, it's nothing to do with the case board, that is just for IDE/USB converter. in your case it is definitely a disk issue, your computer does NOT recognize the driver/partition means the MBA is damaged: If your data is very important, leave it to professional recovery companies (expensive), the less you tried with your drive the better. – Bolu Apr 28 '11 at 16:00
Thanks Dave and Bolu.... Any suggestions on services that might retrieve or restore my drive? – Matt Apr 28 '11 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .