Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 64-bit Home Premium locally and Windows 7 Enterprise remotely via Remote Desktop. The RD window is full screen. Sometimes, when I press Alt-Tab, it is processed by both the remote machine and my local machine. The result is that I get switched to another local window and when I switch back to the RD window, it has switched to another window as well.

This only happens sometimes. If I press Alt-Tab again after switching back to the RD window, it will work correctly. But if I wait about 10 seconds and then try again, the problem happens again.

My local Windows 7 is not patched to SP1, nor is the remote Windows 7.

share|improve this question
    
I have subsequently patched both my local Windows 7 and the remote Windows 7 to Service Pack 1 and I'm still getting this problem. –  dOxxx Jun 24 '11 at 18:47

3 Answers 3

  1. Open the remote desktop connection application
  2. Click the options button
  3. Go to the local resources tab
  4. There will be a box labeled keyboard
  5. Set the option to "on the remote computer"
share|improve this answer
1  
Unfortunately, this doesn't work. –  dOxxx Nov 2 '12 at 13:40

Sure-fire way to "alt tab" inside of an RDP session is to press ALT+PAGE UP

Also, ALT+PAGE DOWN will do the same thing as you'd expect ALT+SHIFT+TAB.

share|improve this answer
    
Those keys do nothing. –  dOxxx Nov 2 '12 at 13:41

These Shortcut Keys might help

  • Alt + PageUp: Move between apps from left to right
  • Alt + PageDown: Move between apps from right to left
  • Alt + Insert: Cycle through apps in the order that they were started
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.