Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed a different os on an usb hard-drive, and when I turn on the computer, it says that so-and-so drive isn't found. The hard-drive on the computer (pc) is on, it's just looking for the usb drive.

I'd like to have it to where when I turn on the computer without the usb drive, it boots Windows 7 like it was a normal day, but when I put in my usb drive, I want to select the os I'd like to use.

My default os is Windows 7, the one on the drive is Ubuntu.

I've been tying to get this to work for 3 days, any help is help to me.

share|improve this question
    
Which boot loader are you using (Windows' or Grub)? –  Ƭᴇcʜιᴇ007 Apr 28 '11 at 16:21

2 Answers 2

You'll need to do two things:

  1. Configure your BIOS to boot from the USB drive before the hard drive. This way, when the USB drive isn't installed, then the boot process will fall-back to booting from your hard drive.

  2. Install a boot manager (such as GRUB, or System Commander if GRUB can't do it) on your USB hard drive, and add an option to boot from your hard drive accordingly.

share|improve this answer

Sounds like you installed an new boot loader on your primary internal hard drive even though you installed the OS on the external drive. (This is the default with most linux installs, unfortunately.) The solution is to restore the windows 7 boot loader. Then use your BIOS options to choose the default boot order. If you configure the USB drive before the internal hard drives then it will boot USB if present and internal (windows 7) if not.

[edit] @Randolf is right... You will also need to install a boot loader on the external drive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.