Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The two emails:

new_email@website.com ( Previously Network Solutions, now a Google Apps account ) other_email@other_website.com ( A Network Solutions email account )

I changed my MX Records for new_email@website.com about 7 months ago to point to Google Apps.

Everything works swimmingly, however :

If I set the mail for other_email@other_website.com to forward to new_email@website.com, then the email gets sent to the old Network Solutions account and not the new Google one, despite the fact that all the MX records clearly only state Google MX Records.

Alternatively, if I were to simply new_email@website.com from other_email@other_website.com then it goes through correctly.

This concludes that if any email address is to send to new_email@website.com, the MX records appropriately redirect to Google Apps. Unless I am using the forwarding system in Network Solutions. Then the account's MX records are ignored, and it is sent to Network Solutions' default MX records instead.

Does anyone know how to correct this problem?

share|improve this question

1 Answer 1

What is probably happening is that the mail handler for other_website.com is not actually doing an MX lookup. I've had hosts before (HostGator and some others) which first do a lookup of other domains attached to the account, and then send the email directly to that domain without actually checking the MX.

I've been able to solve it by setting Remote Mail Exchanger in WHM's MX record control panel. If you don't have access to WHM or an equivalent, talk to support about the issue. There should be some way for them to flag the domain as "not hosting mail", forcing an MX lookup.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.