Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Windows 7 Ultimate 64-bit, and am trying to add a local FTP location to my Windows explorer favorites. For some reason, when I've browsed to say ftp://localaddr, and right click on favorites and click add current location, nothing happens! Is the bookmarking of ftp locations just not supported?

Maybe related: It is a location which requires username/password login (Windows has already saved the password)

share|improve this question
up vote 5 down vote accepted

Open up Explorer and go to C:\Users\<username>\Links then create a new shortcut into this folder. (File -> New -> Shortcut)

Put the address ftp://localaddr into the location field, then hit Next and Finish. You should now have it in your favorites.

share|improve this answer
Thanks, I'll try it when I get home. Do you happen to know if its a genuine bug or this is "works as designed"? Seems to me like either a bad bug or terribly designed UI, disappointing coming from Windows 7... – Suan Apr 28 '11 at 22:16

I found a simpler method at Microsoft's Work with files on an FTP site page:

  1. Open Windows Explorer and navigate to "Computer".
  2. Right-click anywhere in the folder, and then click "Add a network location".  This displays the "Add Network Connection" wizard.
  3. Click "Next".
  4. In the wizard, select "Choose a custom network location", and then click "Next".
  5. Enter the name of the FTP site, with the full ftp:// in front of it, and then click "Next".
  6. To use a name and password, clear the "Log on anonymously" check box, type a user name, and then click "Next".
  7. By default, the name of the shortcut is the same as the FTP address.  If you want to give the shortcut a different name, type it in the "Type a name for this network location" box.  Click "Next".
  8. If you do not want the FTP site to open after you're done setting up the shortcut, clear the "Open this network location when I click Finish" check box.  Click "Finish".  A shortcut to the FTP site appears in the Computer folder.  You can drag that shortcut to your desktop so that it's easy to find later.

One issue I have with this method is that whatever file I open in it opens in my internet browser instead of opening in Windows itself.  I hope there is a way to change it.

share|improve this answer
Links to external resources are encouraged, but please add context around the link so your fellow users will have some idea what it is and why it’s there. Always quote the most relevant part of an important link, in case the target site is unreachable or goes permanently offline. – Ashildr Oct 5 '13 at 12:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.